Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.109 Beiträge in 6.474 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

18-11-2019 22:22:30
JOOM::GALLERY::FORUMArchivJoomGallery 1.5 MVCJoomGallery MVC ALPHA/BETAGelöste Themen: JoomGallery MVCBuild 20091210: Benachrichtigung bei neuem Kommentar
Seiten: [1]
Drucken
Autor Thema: Build 20091210: Benachrichtigung bei neuem Kommentar  (Gelesen 7192 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« am: 13-12-2009 11:01:37 »

Hallo,

ich habe mal eine grundsätzliche Anmerkung zur Versendung der Benachrichtigung bei neuen Kommentaren an denjenigen, der das Bild besitzt.
Wenn ich es richtig verstanden habe, erhält der Besitzer des Bildes nur eine Nachricht, wenn der Kommentar erst noch geprüft werden muss.

Der Bildbesitzer wird mit der Email doch nur neugierig gemacht, kann den neuen Kommentar aber unter Umständen noch gar nicht lesen.
Wäre es nicht sinnvoller, nur eine Nachricht an den Bildbesitzer zu senden, wenn der neue Kommentar schon freigegeben ist und dafür auch einen anderen Text zu nehmen, wie z.B. so was in der Art von "Ihr Bild XY wurde von User XY kommentiert. Schau doch vorbei ...".

Oder vielleicht ist ja auch beides möglich (mit bzw. ohne einem Hinweis auf die fehlende Freigabe).
Nur meine Meinung!

Gruß
Erftralle
« Letzte Änderung: 23-12-2009 17:04:04 von Erftralle » Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #1 am: 14-12-2009 18:36:33 »

Hi,

stimmt, das ist etwas unpassend, so wie es jetzt ist. Im nächsten Build wird es hoffentlich verbessert sein.

Gruß
Chraneco
Gespeichert

Der Sprecher
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« Antworten #2 am: 18-12-2009 17:48:06 »

Hallo Chraneco,

freut mich, dass ihr meine Anregung aufgenommen habt sm_smile .
Ich mach dann mal eine Testreihe auf.

Test 1 (getestet als Gast und registrierter Benutzer):

Backend - Einstellungen:
User Access Rights >>  Admin Approval Needed >> No
General Settings >> Sending method for the comments messages >> Both
General Settings >> Sending method for the comments messages >> Administrator
General Settings >> Message for image owner >> Yes

Ergebnis
Weder der Administrator noch der Eigentümer des Bildes erhalten eine Mail oder eine Message.

Test 2 (getestet als Gast):

Backend - Einstellungen:
User Access Rights >>  Admin Approval Needed >> only unregistered users
General Settings >> Sending method for the comments messages >> Both
General Settings >> Sending method for the comments messages >> Administrator
General Settings >> Message for image owner >> Yes

Ergebnis
Der Administrator erhält eine Message aber keine Mail. Korrektur: Mail ist auch ok.
Der Eigentümer erhält nach der Freigabe weder eine Message noch eine Mail.

Test 3 (getestet als registrierter Benutzer):

Backend - Einstellungen:
User Access Rights >>  Admin Approval Needed >> only unregistered users
General Settings >> Sending method for the comments messages >> Both
General Settings >> Sending method for the comments messages >> Administrator
General Settings >> Message for image owner >> Yes

Ergebnis
Weder der Administrator noch der Eigentümer des Bildes erhalten eine Mail oder eine Message.

Weitere Tests und Ergebnisse folgen ...

Gruß
Erftralle
« Letzte Änderung: 18-12-2009 18:30:51 von Erftralle » Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #3 am: 18-12-2009 18:50:10 »

Hi,

vielen Dank für die ausführlichen Tests! Ich habe verschiedene Fehler gefunden, im Anhang findest du ein Zip mit geänderten Dateien, ich werde es mit dem Erscheinen des nächsten Builds dann wieder löschen.

Im Moment ist das Ganze so konzipiert, dass eine Nachricht an die ausgewählten Benutzer nur verschickt wird, wenn der Kommentar überprüft werden muss. Nur der Bildbesitzer erhält immer eine Nachricht (aber natürlich nur, wenn dies so eingestellt ist). Das ist mir auch erst wirklich klar geworden sm_smile.
Fändest du ein anderes Verhalten besser?

Gruß
Chraneco
« Letzte Änderung: 18-12-2009 20:51:49 von Chraneco » Gespeichert

Der Sprecher
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« Antworten #4 am: 18-12-2009 18:57:55 »

Hi,

ich war ja noch gar nicht ganz fertig, alter Mann ist ja kein D-Zug sm_wink .

Zitat
Im Moment ist das Ganze so konzipiert, dass eine Nachricht an die ausgewählten Benutzer nur verschickt wird, wenn der Kommentar überprüft werden muss.

Das finde ich im Prinzip auch in Ordnung so, man sollte dies aber in der Backend - Konfiguration explizit erwähnen.
Ich meine auch, dass es im vorangegangenen Build (20091210) nicht so gewesen ist, oder?

Dann teste ich mal die neuen Dateien.

Gruß
Erftralle
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #5 am: 18-12-2009 19:02:57 »

Hi,

Zitat von: Erftralle
ich war ja noch gar nicht ganz fertig, alter Mann ist ja kein D-Zug sm_wink.

Tut mir leid, diese Fehler hätten mir aber eigentlich auch schon selbst früher auffallen müssen sm_smile.

Zitat von: Erftralle
Das finde ich im Prinzip auch in Ordnung so, man sollte dies aber in der Backend - Konfiguration explizit erwähnen.

Stimmt, das werde ich auch noch ändern.

Zitat von: Erftralle
Ich meine auch, dass es im vorangegangenen Build (20091210) nicht so gewesen ist, oder?

Wenn ich mich richtig erinnere, war es im vorangegangenen Build so, dass überhaupt keine Nachrichten verschickt wurden, wenn der Kommentar nicht überprüft werden musste.

Gruß
Chraneco
Gespeichert

Der Sprecher
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« Antworten #6 am: 18-12-2009 19:48:09 »

Hi Chraneco,

Zitat von: Chraneco
Wenn ich mich richtig erinnere, war es im vorangegangenen Build so, dass überhaupt keine Nachrichten verschickt wurden, wenn der Kommentar nicht überprüft werden musste.
Sorry, kann sein ,das ich das falsch erinnere. Du solltest es ja bessert wissen sm_yes .

Und jetzt die neuen Ergebnisse:

Zunächst musste ich ein
Code
print_r($message);die;
 
aus components/com_joomgallery/models/comments.php entfernen sm_wink .

Test 1 (getestet als Gast und registrierter Benutzer):

Backend - Einstellungen:
User Access Rights >>  Admin Approval Needed >> No
General Settings >> Sending method for the comments messages >> Both
General Settings >> Sending method for the comments messages >> Administrator
General Settings >> Message for image owner >> Yes


Ergebnis:
Der Bildbesitzer erhält eine Mail und eine Nachricht "JGS_NEW_COMMENT_MESSAGE_TO_OWNER" mit Betreff "JGS_NEW_COMMENT_MESSAGE_TO_OWNER_SUBJECT".

Test 2 (getestet als Gast und registrierter Benutzer):

Backend - Einstellungen:
User Access Rights >>  Admin Approval Needed >> only unregistered users
General Settings >> Sending method for the comments messages >> Both
General Settings >> Sending method for the comments messages >> Administrator
General Settings >> Message for image owner >> Yes


Ergebnis:
Test bis auf die fehlenden Sprachkonstanten "JGS_NEW_COMMENT_MESSAGE_TO_OWNER" und "JGS_NEW_COMMENT_MESSAGE_TO_OWNER_SUBJECT " erfolgreich.

Test 3 (getestet als Gast und registrierter Benutzer):

Backend - Einstellungen:
User Access Rights >>  Admin Approval Needed >> also registered users
General Settings >> Sending method for the comments messages >> Both
General Settings >> Sending method for the comments messages >> Administrator
General Settings >> Message for image owner >> Yes


Ergebnis:
Test von der Funktionalität her wieder in Ordnung.
Der Administrator erhält, obwohl ein registrierter Benutzer kommentiert, die Nachricht
Zitat
A new comment from Guest has been ...

Ok, fertig.

Gruß
Erftralle
« Letzte Änderung: 18-12-2009 20:19:58 von Erftralle » Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #7 am: 18-12-2009 20:51:55 »

Hi,

vielen Dank!
Ich habe oben ein neues Zip mit weiteren Anpassungen angehängt.
Wenn ich es richtig verstanden habe, funktioniert dann außer den noch fehlenden Sprachkonstanten alles, so wie es soll, oder?

Gruß
Chraneco
Gespeichert

Der Sprecher
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« Antworten #8 am: 18-12-2009 21:05:38 »

Hi,
nicht ganz (siehe Test 3).

Der Administrator erhält, obwohl ein registrierter Benutzer kommentiert, die Nachricht
Zitat
A new comment from Guest has been ...

Wenn der registrierte Benutzer "Chraneco" hieße, würde ich
Zitat
A new comment from Chraneco has been ...
erwarten.

Gruß
Erftralle
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #9 am: 18-12-2009 21:12:41 »

Hi,

dieses Problem sollte mit den neuen Dateien ebenfalls erledigt sein, zumindest waren meine Tests jetzt erfolgreich, aber vielleicht habe ich etwas übersehen.

Gruß
Chraneco
Gespeichert

Der Sprecher
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« Antworten #10 am: 18-12-2009 21:23:30 »

Hi,

bin gerade dabei es zu testen.
Ich dachte, du hättest diesen Hinweis von mir vielleicht überlesen. Du hattest ja nicht erwähnt, was du noch geändert hast.

Melde mich gleich nochmal.

Gruß
Erftralle
Gespeichert
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« Antworten #11 am: 18-12-2009 21:28:51 »

Hi,
das mit dem Benutzernamen hat sich jetzt auch erledigt, super.

Gruß
Erftralle

Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #12 am: 19-12-2009 13:34:38 »

Hi,

achso, ok, tut mir leid, dass ich das nicht erwähnt hatte, ich wollte es wohl nur sehr schnell erledigt haben sm_smile.

Dann noch mal vielen Dank für die Tests!

Gruß
Chraneco
Gespeichert

Der Sprecher
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« Antworten #13 am: 19-12-2009 16:15:37 »

Hallo Chraneco,

gerne geschehen  sm_yes .

Gruß
Erftralle
Gespeichert
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« Antworten #14 am: 19-12-2009 18:21:22 »

Hi,

bis auf die fehlenden Definitionen der Sprachkonstanten "JGA_NEW_COMMENT_MESSAGE_TO_OWNER_SUBJECT" und "JGA_NEW_COMMENT_MESSAGE_TO_OWNER" alles i.O. .

Gruß
Erftralle
Gespeichert
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 4865 access attempts in the last 7 days.