JOOM::GALLERY::FORUM

Archiv => Gelöste Themen: Installation => Thema gestartet von: vgerdes am 24-08-2010 10:22:50



Titel: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 10:22:50
Hallo zusammen,

ich habe vorhin den Hinweis bekommen, dass eine neue Version von JoomGallery vorliegt und habe die Installation gestartet.

Alles lief ohne Fehler durch und ich dachte schon prima, hat super geklappt.

Nun habe ich in den Artikel immer Bilder aus der Gallerie eingebunden und die werden nun nicht mehr gezeigt.

Ich habe sie eingebunden in der Form:
http://www.seite.de/index.php?option=com_joomgallery&func=watermark&catid=14&id=766&Itemid=109

Und genau dieses funktioniert nach dem Update nicht mehr.

Gibt es dafür einen Workaround, den ich noch nicht gefunden habe?

In der Gallerie werden die Bilder nach wie vor angezeigt, doch eben nicht mit dieser Einbindung.

Was kann ich tun?

Viele Grüße

Volker


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: Chraneco am 24-08-2010 12:02:14
Hi,

der Aufbau der Links der Galerie haben sich leider geändert, du musst wohl oder übel die Artikel überarbeiten. Vielleicht kannst du mit Hilfe von PhpMyAdmin auch ein Suchen und Ersetzen durchführen.

Warum hast du nicht das Content-Plugin verwendet? Es würde jetzt automatisch die neuen Links einsetzen.

Gruß
Chraneco


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 12:42:10
Das kenne ich nicht .......

Ich habe über 4700 Bilder in der Gallerie die in über 4000 Beiträge eingebunden sind :-(



Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: Chraneco am 24-08-2010 13:31:13
Hi,

du findest es hier (http://www.joomgallery.net/downloads/joomgallery-fuer-joomla-15/plugins/content-plugin-joomplu.html) und hier (http://www.joomgallery.net/downloads/joomgallery-fuer-joomla-15/plugins/editorbutton-joombu.html) das entsprechende Editorbutton-Plugin zum Einfügen.

Dann versuche bitte eine 'Suchen und Ersetzen'-Aktion mit Hilfe von PhpMyAdmin, du müsstest 'func=watermark' mit 'view=image&format=raw&type=img' ersetzen, aber lege bitte ein Backup vorher an.

Gruß
Chraneco


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 13:42:38
Ich werde es am Wochenende mal mit viel Ruhe probieren.

DANKE erst mal !!


Volker


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: Chraneco am 24-08-2010 13:49:28
Hi,

alles klar, ich würde mich über eine Rückmeldung dann sehr freuen. Vielen Dank schon mal dafür!

Gruß
Chraneco


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 13:52:02
VERSPROCHEN !


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 14:10:01
Magst Du bitte noch mal auf meinen "Suchen und Ersetzen" Befehl schauen?

Will nur sicher gehen :-)


UPDATE jos_content SET introtext = REPLACE(introtext, 'func=watermark', 'view=image&format=raw&type=img')
UPDATE jos_content SET fulltext = REPLACE(fulltext, 'func=watermark', 'view=image&format=raw&type=img')


Dann eine Frage zum "Natives Plugin für sh404SEF 1.5":
Dort steht "Die Datei in dem Zip muss in das Verzeichnis'/components/com_sh404sef/sef_ext' kopiert werden."

Das Verzeichnis habe ich nicht. Wird das beim Update auf die 1.5.5 angelegt oder muss ich es manuell anlegen? (Habe die Seite komplett aus dem Backup wiederhergestellt. Ist also wieder die 1.5.0.5)

Fragen über Fragen :-)


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: Chraneco am 24-08-2010 14:23:26
Hi,

der Befehl müsste passen. Da du ja ein Backup hast, teste ihn bitte einfach mal.

Der Ordner gehört zur Komponente sh404SEF. Wenn du diese Komponente nicht installiert hast, brauchst du dieses Plugin gar nicht.

Gruß
Chraneco


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 14:33:50
OK, ich habe es jetzt einfch mal durchgeführt.

Das Update lief wieder einwandfrei durch.

Der erste SQL-Befehl lief auch durch und die Bilder werden auch wieder angezeigt, aber ohne Wasserzeichen

Der zweite SQL-Befehl lief auf einen Syntaxfehler, den ich nicht finde .....



Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 14:37:47
Wasserzeichen wird angezeigt, aber nicht meins. Das bekomme ich aber wieder hin!


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: Chraneco am 24-08-2010 14:38:48
Hi,

einen Syntaxfehler kann ich leider auch nicht entdecken, an welcher Stelle wurde er genau angezeigt?

Gruß
Chraneco


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 14:40:17
 SQL-Befehl:

UPDATE jos_content SET FULLTEXT = REPLACE (

FULLTEXT ,
'func=watermark',
'view=image&format=raw&type=img'
)

MySQL meldet: Dokumentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'fulltext = REPLACE(fulltext, 'func=watermark', 'view=image&format=raw&ty' at line 1


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: Chraneco am 24-08-2010 14:44:35
Hi,

ok, versuche es mal bitte mit diesem:

Code
UPDATE jos_content SET fulltext = REPLACE(fulltext, 'func=watermark', 'view=image&type=img&format=raw')

Ich glaube zwar nicht, dass das dann funktioniert, aber mich würde die Fehlermeldung interessieren.

Gruß
Chraneco


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 14:49:43
 SQL-Befehl:

UPDATE jos_content SET FULLTEXT = REPLACE (

FULLTEXT ,
'func=watermark',
'view=image&type=img&format=raw'
)

MySQL meldet: Dokumentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'fulltext = REPLACE(fulltext, 'func=watermark', 'view=image&type=img&form' at line 1


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 14:51:25
Der Unterschied zwischen beiden SQL-Statements ist doch nur der Feldname.

Ist FULLTEXT irgendwie geschützt?


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: Chraneco am 24-08-2010 15:05:19
Hi,

jep, das wundert mich auch.

Ich habe es bei mir jetzt auch mal ausprobiert und habe zuerst die gleiche Fehlermeldung erhalten.

Versuche es mal bitte mit diesem Befehl:

Code
UPDATE jos_content SET jos_content.fulltext = REPLACE(jos_content.fulltext, 'func=watermark', 'view=image&format=raw&type=img')

Ich verstehe zwar nicht warum, aber mit diesem hat es bei mir dann funktioniert.

Gruß
Chraneco


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 15:08:15
SUPER !!

Vielen Dank !!!


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: Chraneco am 24-08-2010 15:10:42
Hi,

kein Problem. Ich hoffe, damit klappt dann jetzt alles.

Gruß
Chraneco


Titel: Re: Bilder werden nach Update auf 1.5.5 nicht mehr angezeigt
Beitrag von: vgerdes am 24-08-2010 15:12:30
einen Fehler habe ich noch gefunden, doch damit mache ich einen neuen Thread auf, da es nichts hiermit zu tun hat.

Nochmals vielen Dank für Deine tolle Hilfe.

Nun habe ich das Wochenende frei :-)

DANKE!


Volker