JOOM::GALLERY::FORUM

Archiv => Gelöste Themen: Migration => Thema gestartet von: shark007 am 27-08-2010 23:11:27



Titel: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: shark007 am 27-08-2010 23:11:27
Hallo Zusammen ich möchte meine ponygallery 2.5.1 auf joomla! 1.0.x migrieren zur JoomGallery 1.5.5 auf Joomla! 1.5.x die Migrationsanleitung habe ich soeben gelesen. Gemäss Anleitung muss ich meine Daten zuerst in die JoomGallery 1.0.0 laden und dann updaten. Mein Problem ist dass ich die JoomGallery 1.0.0 nirgens mehr zum download finde? Oder habe ich etwas falsch verstanden was die Migration anbelangt.

Vielen Dank für die Hilfe
Gruss shark007


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: Claudia E. am 28-08-2010 06:25:19
Nein, du hast das absolut richtig verstanden.
Ich denke, einer der Entwickler wird noch die alte Version haben - aber vielleicht wäre es wirklich besser, für solche Fälle die Version 1.0 weiterhin zum Download anzubieten? (Frage ans Team)

Alternativ könntest du auch folgenden Weg gehen:
- Installation der portierten Pony (http://www.joomlaportal.de/ver-ffentlichungen-von-komponenten-modulen-templates/143234-portierte-version-der-ponygallery-ml-2-5-1-a.html) von Chraneco unter Joomla 1.5
- Übernahme der Datenbanktabellen per phpMyAdmin
- Übernahme der Bilder per FTP
- Anschließend Installation der JoomGallery und Migration per Migrations-Manager im Backend der Joom


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: aHa am 28-08-2010 11:59:15
Hallo,

@shark007: Im Beitrag unten findest Du die JoomGallery 1.0 als Vollinstallationszip.
Bitte führe unbedingt Backups durch und probiere die Migrationsschritte zuerst in einem Testsystem durch.

@Claudia: Wir haben uns bewusst von alten Versionen getrennt und bieten diese nicht in einem gesonderten Downloadbereich an.
Wie in diesem Fall stellen wir natürlich vereinzelt Versionen zur Verfügung

Gruß
Andreas


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: Claudia E. am 28-08-2010 19:28:47
@ Andreas

Das verstehe ich natürlich, ich dachte nur, eben für solche Fälle...
Ich hab sie mir jetzt selbst noch mal runtergeladen, vorsichtshalber für erneute Anfragen. :-)


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: shark007 am 29-08-2010 22:00:37
Danke für die superschnelle Antwort, das Update auf joomgallery 1.0.0 hat problemlos funktioniert.

Nun bin ich bei folgendem Punkt angelangt:
Installation der Updatekomponente (1.5) über das Backend von Joomla! (Erweiterungsmanager).

wo finde ich die Updatekomponente?

gruss shark007


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: Chraneco am 29-08-2010 22:15:04
Hi,

in unseren Downloads unter 'Komponente' der entsprechenden JoomGallery-Version. Das Update-Paket entspricht seit Kurzem dem Installationspaket.

Gruß
Chraneco


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: shark007 am 30-08-2010 18:42:23
Wenn ich die aktuelle JoomGallery (1.5.5.2) aus den Downloads via Backend installiere, dann habe ich wohl die neuste Version der Gallery, aber meine Datenbank ist dadurch ja noch nicht aktualisiert also noch auf der 1.0.0 Version.

Wie migriere ich die DB auf die neuste Version?

es grüsst shark007


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: Chraneco am 30-08-2010 18:44:06
Hi,

das erledigt das Update-Script der neuen Version dann automatisch.

Gruß
Chraneco


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: Timber am 06-09-2010 00:04:50
Hi,

das erledigt das Update-Script der neuen Version dann automatisch.

Gruß
Chraneco

Hallo Chraneco,

ich habe jetzt die Pony Version auf einer neuen 1.5 Joomla Version laufen. Habe alle Bilder und auch die Datenbank von der alten Joomla Version 1.0 importiert, läuft alles. Nun habe ich die neueste Joomla Galerie installiert und die Migration gestartet, bekomme keine Fehlermeldung und kann die Migration ausführen. Allerdings gibt es kein Ergebnis, es hat sich nicht getan, es wurde nichts übernommen. Nun wollte ich über deine Pony Version die erste JoomlaGalerie 1.0 installieren und im Legacy Modus die Migration durchlaufen lassen, um die neueste anschließend aufzuspielen, jetzt finde ich aber nirgends die JoomlaGalerie 1.0 habt ihr die noch irgendwo?

Gruß Volker 


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: Timber am 06-09-2010 00:26:15
Hi,

das erledigt das Update-Script der neuen Version dann automatisch.

Gruß
Chraneco

Hallo Chraneco,

ich habe jetzt die Pony Version auf einer neuen 1.5 Joomla Version laufen. Habe alle Bilder und auch die Datenbank von der alten Joomla Version 1.0 importiert, läuft alles. Nun habe ich die neueste Joomla Galerie installiert und die Migration gestartet, bekomme keine Fehlermeldung und kann die Migration ausführen. Allerdings gibt es kein Ergebnis, es hat sich nicht getan, es wurde nichts übernommen. Nun wollte ich über deine Pony Version die erste JoomlaGalerie 1.0 installieren und im Legacy Modus die Migration durchlaufen lassen, um die neueste anschließend aufzuspielen, jetzt finde ich aber nirgends die JoomlaGalerie 1.0 habt ihr die noch irgendwo?

Gruß Volker 

Ok, wer lesen kann, ist klar im Vorteil, jetzt habe ich den Anhang weiter oben auch gesehen. Trotzdem danke.


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: shark007 am 10-10-2010 20:31:39
Ich wollte mich hier noch für die schnelle und tolle Unterstützung bedanken. Es hat funktioniert und ich konnte meine Pony ML mit über 6000 Fotos in ca. 60 Kategorien auf die neuste JoomGallery migrieren - toll!

gruss shark007


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: msit am 05-08-2011 12:47:21
Hallo,

@shark007: Im Beitrag unten findest Du die JoomGallery 1.0 als Vollinstallationszip.
Bitte führe unbedingt Backups durch und probiere die Migrationsschritte zuerst in einem Testsystem durch.

@Claudia: Wir haben uns bewusst von alten Versionen getrennt und bieten diese nicht in einem gesonderten Downloadbereich an.
Wie in diesem Fall stellen wir natürlich vereinzelt Versionen zur Verfügung

Gruß
Andreas

Hallo zusammen!

Vielleicht bin ich ja einfach zu dämlich!


Hintergrund ist, dass ich langsam auf Joomla 1.7 wechseln will und damit unter anderem von der
PonyGallery ML
By: M. Andreas Böttcher (mab) & Benjamin Malte Meier (b2m)
& Andreas Hartmann (aHa) & The ML-Team
[Based on: PonyGallery by Danial Taherzadeh]
Version 2.5.1 PORTED J! 1.5.3, BUILD 20080619

auch auf die neueste Joomgallery.

UPDATE:

Also: Joomgallery 1.0 installieren habe ich jetzt geschafft, nachdem ich den FTP layer in Joomla Global configuration/Server ausgeschaltet habe!

Allerings kommen jetzt beim Migrations-Check folgende Fehler:

Existence and Integrity of Databasetables
jos_joomgallery: row(s)         
jos_joomgallery_catg: row(s)         
jos_joomgallery_comments: row(s)         
jos_joomgallery_votes: row(s)         
jos_joomgallery_nameshields: row(s)         
jos_ponygallery: No database selected         
jos_ponygallery_catg: No database selected         
jos_ponygallery_comments: No database selected         
jos_ponygallery_votes: No database selected         
jos_ponygallery_nameshields: No database selected    

Einziger Hinweis: Man soll's reparieren! Fragt sich nur wie und wo???     
Welche row(s), und was damit machen??? Wo database selektieren ???

Hat jemand einen Tipp? (Bzw. eine aussagekräftige Beschreibung, - ist ja eh schon umständlich genug  :'-()

Bin dankbar für jede Hilfe!

Martin


Titel: Re: von pony 2.5.1 zu joom gallery 1.0.0
Beitrag von: sebidebeschte am 23-06-2012 15:32:11
Hallo,
ich habe nach der Anleitung hier auf der Seite die Migration von Pony ML durchgeführt.
Es gab auch keine Fehler.
Nur werden nun die Bilder nicht angezeigt.
habe alle Bilder per FTP hochgeladen in die Ordner
components/com_joomgallery/img_originals
components/com_joomgallery/img_pictures
components/com_joomgallery/img_thumbnails

muss ich noch mehr dateien uploaden ?

Die Datenbankstruktur stimmt und ich bekomme auch die Links angezeigt. Nur die Bilder selbst nicht ???
Weiß nicht warum..

Hat da jemand einen Tipp ?

mfg
Sebi