JOOM::GALLERY::FORUM

JoomGallery 3.x JUX => Zusammenspiel mit anderen Komponenten => Thema gestartet von: xDavid am 08-08-2017 15:21:57



Titel: Probleme im Zusammenspiel mit Phoca Open Graph System Plugin
Beitrag von: xDavid am 08-08-2017 15:21:57
Hallo,

es gibt offenbar Probleme beim Zusammenspiel von JoomGallery und Phoca Open Graph System Plugin (fügt Nicht-Content-Seiten Open-Graph-Tags hinzu). Jeweils neueste Versionen auf Joomla 3.7.4.

Solange dieses Plugin aktiviert ist, zeigt JoomGallery in der Detail-Ansicht das Bild nicht an, man kann es auch nicht herunterladen (nicht gefunden). Auch wenn man den Artikel mit dem JoomImg-Button in einen Artikel einbindet, wird das Bild im Artikel nicht angezeigt.

Detail-Ansicht: https://www.martin-luther-king-kirche.de/website/galerie/spruchkarten-soschumolevers/2016-17/august-september-2017-767 (https://www.martin-luther-king-kirche.de/website/galerie/spruchkarten-soschumolevers/2016-17/august-september-2017-767)

Bild im Artikel: https://www.martin-luther-king-kirche.de/gemeinde/gemeindebrief/gruppen/463-aus-der-sonntagsschule-august-september-2017 (https://www.martin-luther-king-kirche.de/gemeinde/gemeindebrief/gruppen/463-aus-der-sonntagsschule-august-september-2017)

Das Plugin fügt lediglich 6 Zeilen zum Header-Bereich hinzu, die aber nicht das Problem sind. Wenn ich sie händisch an die gleiche Stelle in die index.php eines Templates auf einer anderen Website einbaue, ohne dass das Plugin installiert ist, stört das JoomGallery überhaupt nicht.

https://www.molthagen.de/michael/inhalte/galerie/luftfahrzeuge/luftrettung-d-hdrb-148 (https://www.molthagen.de/michael/inhalte/galerie/luftfahrzeuge/luftrettung-d-hdrb-148)

Irgend eine Idee, warum das Plugin und JoomGallery nicht miteinander können?


Danke schon einmal & Grüßle

Michael


Titel: Re: Probleme im Zusammenspiel mit Phoca Open Graph System Plugin
Beitrag von: Erftralle am 09-08-2017 14:48:14
Hallo,

es liegt am Phoca Open Graph System Plugin, näheres siehe hier (http://www.joomgallery.net/faq/allgemeines/detailbilderoriginalbilder-werden-nicht-angezeigt.html) und hier (http://www.joomgallery.net/faq/allgemeines/problem-mit-bestimmten-system-plugins.html).

Ändere Zeile 53 der plugins/system/phocaopengraph/phocaopengraph.php mal

von
Code:
if ($format == 'feed' || $format == 'pdf' || $format == 'json') {

nach
Code:
if ($format == 'feed' || $format == 'pdf' || $format == 'json' || $format == 'raw') {

Bei mir werden dann die Bilder wieder angezeigt.

Gruß
Erftralle


Titel: Re: Probleme im Zusammenspiel mit Phoca Open Graph System Plugin
Beitrag von: xDavid am 13-08-2017 10:15:17
Hallo,

ganz herzlichen Dank für die kompetente Hilfe - jetzt funktioniert es tatsächlich.

Ich gebe das an den Entwickler des Plugins weiter (ich gehe davon aus, dass Du nichts dagegen hast).


Grüße

Michael