JOOM::GALLERY::FORUM

Archiv => Uploads => Thema gestartet von: Coolmaxl am 08-11-2008 11:28:12



Titel: Bilderupload geht nicht mehr.
Beitrag von: Coolmaxl am 08-11-2008 11:28:12
Hi,
ich habe folgendes Problem, ich hab meinen Server von PHP4 auf PHP5 umstellen lassen.
Seitdem funktioniert alles in der Gallery noch super, bis auf die Bilderuploads.
Hab schon massig gegoogelt und hier im Forum rumgestöbert. Ich finde aber keine Lösung.

Im Backend von Joomla 1.0 steht seit der Umstellung:
    * PHP magic_quotes_gpc setting is `OFF` instead of `ON`
    * PHP register_globals setting is `ON` instead of `OFF`
ich weiß net ob das was damit zu tun hat, damit der Upload nemma funzt.

Wenn ich z.B. ein einzelnes Bild hochladen will schreibt er nachdem ich auf Hochladen geklickt
hab das das Bild hochgeladen wurde. Schau ich im Manager nach, ist kein Bild in meiner
ausgewählten Kategorie.
Wenn ich Batch Upload mache, dann schreibt er nach upload: 1 Dateien im Batch gefunden,
gehe ich wieder in den Manager befindet sich wieder kein Bild in der Kategorie.
Beim FTP Upload baut sich das Bild einfach neu auf und alles ist wie vorher, es stehen
dann nach wie vor alle dateien drin, die ich in die Gallery laden könnte.

Verzeichnisberechtigungen sind gesetzt, daran liegt es auch net. Hatte sogar mal alles auf 777,
hat aber auch nix geholfen.

Kann mir bei dem Problem irgendwer helfen? Ich verzweifel. :sm_dead: :sm_dead: :sm_dead:

Danke schon mal


Titel: Re: Bilderupload geht nicht mehr.
Beitrag von: aHa am 09-11-2008 21:24:31
Hallo,
welche Joomla! Version 1.0.x ist bei Dir installiert?
Läuft PHP5 im Unterschied zu dem vorherigen PHP4 jetzt als Apachemodul oder im CGI/FCI Modus?
Gibt es Probleme mit anderen Funktionen? Kannst Du z.B. ein Bild ohne Probleme mit dem Joomla Media Manager hochladen?

Gruß
Andreas


Titel: Re: Bilderupload geht nicht mehr.
Beitrag von: Coolmaxl am 10-11-2008 19:10:29
Database Version:              5.0.41
PHP Version:                    5.0.4
Web Server:                    Apache/2.0.54 (Fedora)
WebServer to PHP interface:    apache2handler
Joomla! Version:            Joomla! 1.0.13 Stable [ Sunglow ] 21 July 2007 16:00 UTC
User Agent:                    Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Relevant PHP Settings:
Joomla! Register Globals Emulation:    OFF
Register Globals:                    ON    
Magic Quotes:                            OFF    
Safe Mode:                            OFF    
File Uploads:                            ON    
Session auto start:                    OFF    
Session save path:                    /var/lib/php/session
Short Open Tags:                    ON    
Output Buffering:                    OFF    
Open basedir:                            /var/www/vhosts/xxx/httpdocs:/tmp
Display Errors:                    OFF
XML enabled:                            Yes
Zlib enabled:                            Yes
Disabled Functions:                    none

Soviel zu dem Thema. Dann wollt ich mal den Media Manager ausprobieren, das Funzt auch nemma.
Hab ich bis Dato noch net probiert.
PS Mir ist bei die Berechtigungen noch aufgefallen, das mein Session Directory /var/lib/php/session/
Unwriteable ist.


Titel: Re: Bilderupload geht nicht mehr.
Beitrag von: Mogwai am 19-11-2008 15:10:51
Hallo!

Soviel zu dem Thema. Dann wollt ich mal den Media Manager ausprobieren, das Funzt auch nemma.
Also was den Mediamanager betrifft, würde ich mal probieren den Flash-Uploader zu deaktivieren.

Greets
Mogwai


Titel: Re: Bilderupload geht nicht mehr.
Beitrag von: aHa am 22-11-2008 02:52:51
Hallo,
ein 'wenig' verspätet noch eine Antwort.
Zitat
WebServer to PHP interface:    apache2handler

War dies auch unter PHP4 so eingestellt? Du könntest Deinen Hoster fragen, ob durch die Umstellung Änderungen an den Besitzrechten der Dateien vorgenommen wurden.
Auch wegen des Problems mit dem Verzeichnis '/var/lib/php/session/' müsstest Du nachfragen, weil Du wahrscheinlich auf dieses zentrale Serververzeichnis keinen Zugriff hast.

Zu einem Update auf Joomla 1.0.15 rate ich Dir aus Sicherheitsgründen.

Gruß
Andreas