JOOM::GALLERY::FORUM

Archiv => Gelöste Themen: Installation => Thema gestartet von: photo-andre am 09-11-2008 11:50:14



Titel: "Favoriten" funktioniert nicht :-(
Beitrag von: photo-andre am 09-11-2008 11:50:14
Wollte nach dem Update nun heute meinen Usern die Favoriten-Funktion (ohne download nur zum online abspeichern) zur Verfügung stellen.
Leider mußte ich feststellen, dass tortz klicken auf den Favoriten-Stern in der Detailansicht und trotz der Meldung, dass das Bild in die Favoriten übernommen wurde, die Anzeige unter "Meine Favoriten" leer bleibt mit der Anzeige, dass man keine Favoriten hat.  ::)

Vielleicht nur ein kleiner Bug, aber wäre super wenn man den beheben könnte.

System: Joomla 1.5.7 legacy Modus, aktuelle JoomGallery-Version mit gefixter DB zur Autoren-Übernahme für CBE1.3 (für Joomla 1.5)

Grüßle André

PS. Hoffe ich hab kein Posting zu dem Thema übersehen. ;D


Titel: Re: "Favoriten" funktioniert nicht :-(
Beitrag von: Chraneco am 09-11-2008 12:00:29
Hi,

auch für die Favoriten ist eine zusätzliche DB-Query nötig, falls man die JoomGallery nicht neu installiert hat.

Code
CREATE TABLE `#__joomgallery_users` (
 `uid` int(11) NOT NULL AUTO_INCREMENT,
 `uuserid` int(11) NOT NULL DEFAULT '0',
 `piclist` varchar(1000) DEFAULT NULL,
 `layout` int(1) NOT NULL,
 `time` datetime NOT NULL,
 `zipname` varchar(70) NOT NULL,
 PRIMARY KEY  (`uid`),
 INDEX idx_uid (`uuserid`)
) ENGINE=MyISAM ;

Gruß
Chraneco


Titel: Re: "Favoriten" funktioniert nicht :-(
Beitrag von: photo-andre am 09-11-2008 14:57:50
Hi,

auch für die Favoriten ist eine zusätzliche DB-Query nötig, falls man die JoomGallery nicht neu installiert hat.

Code
CREATE TABLE `#__joomgallery_users` (
 `uid` int(11) NOT NULL AUTO_INCREMENT,
 `uuserid` int(11) NOT NULL DEFAULT '0',
 `piclist` varchar(1000) DEFAULT NULL,
 `layout` int(1) NOT NULL,
 `time` datetime NOT NULL,
 `zipname` varchar(70) NOT NULL,
 PRIMARY KEY  (`uid`),
 INDEX idx_uid (`uuserid`)
) ENGINE=MyISAM ;

Gruß
Chraneco

 ::)Übersehe ich neuerdings Postings mit solchen Hinweisen, oder kommen die wirklich nur auf Nachfrage? :(

Ansonsten sollte man das vielleicht in einer Readme Datei in das Update mal mit einfügen.  ;-))

Danke für die Info!


Titel: Re: "Favoriten" funktioniert nicht :-(
Beitrag von: photo-andre am 09-11-2008 15:20:47
DB-Query ohne Erfolg! Speicherbestättigung für das Bild gib es zwar, aber die Ansicht "meine Favoriten" bleibt leer mit der Anzeige "keine Bilder ausgewählt"!  :(


Titel: Re: "Favoriten" funktioniert nicht :-(
Beitrag von: Hypnotoad am 09-11-2008 18:29:22
Gab es denn beim Erstellen der Tabelle in phpMyAdmin o.Ä. irgend eine Rückmeldung oder Fehlermeldung?
Auf jeden Fall müsste die Query angepasst werden, bevor man sie selbst ausführt. Z.B. für "jos" als DB-Prefix:

Code
CREATE TABLE `jos_joomgallery_users` (
 `uid` int(11) NOT NULL AUTO_INCREMENT,
 `uuserid` int(11) NOT NULL DEFAULT '0',
 `piclist` varchar(1000) DEFAULT NULL,
 `layout` int(1) NOT NULL,
 `time` datetime NOT NULL,
 `zipname` varchar(70) NOT NULL,
 PRIMARY KEY  (`uid`),
 INDEX idx_uid (`uuserid`)
) ENGINE=MyISAM ;


Titel: Re: "Favoriten" funktioniert nicht :-(
Beitrag von: photo-andre am 10-11-2008 20:45:53
 ::)Hab vergessen das Querry anzupassen!  ::)

Bitte nicht hauen! ::)

Nun läuft aber alles! Herzlichen Danke! :sm_yes: