mouth
Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.112 Beiträge in 6.477 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

29-05-2020 00:30:36
JOOM::GALLERY::FORUMArchivJoomGallery 1.5 MVCMigrationGelöste Themen: MigrationRe: Migration von portierter Pony in neuer Joom, Pony macht Macken
Seiten: [1]
Drucken
Autor Thema: Re: Migration von portierter Pony in neuer Joom, Pony macht Macken  (Gelesen 6328 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
Karatenews
Newbie
*
Offline Offline

Beiträge: 16


« am: 04-01-2009 10:10:42 »

Hallo miteinander,

ich bin auch gerade dabei meine Seite von einer 1.0.15 Version auf die 1.5 umzustellen. Hierbei habe ich eine zweite Seite mit 1.5 hochgezogen, um die neue Community parallel aufzubauen.

Von der Pony habe ich die Portierte Version installiert und alle alten TAbellen in die neue Seite importiert, was auch hervorragend geklappt hat. Die Joomgallerie installiert um das Migrationstool auszuführen. Alles ist grün bis auf die Meldung Orphans (Pictures without valid user): 2

Im Forum hier steht, das kommt daher das mal ein User seinen Namen geändert hat.
DA ich über 5000 Mitglieder habe, ist es unmöglich hier alles durchzuschauen, also habe ich die Bilder der Userbooks, auf welchen Mitglieder uploaden können aus der Datenbank komplett entfernt, so das lediglich nur noch der Admin bei den Bildern in der DB drin steht. Trotzdem verschwindet die Meldung nicht.

Die Bilder habe ich noch nicht auf den neuen Server umgezogen, kann es daran liegen? Eigentlich sind ja in erster Linie die Tabellen wichtig oder? Wenn ich im Backend den Picture Manager der portierten Pony öffnen möchte kommt auch folgender Fehler: Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 786432 bytes) in /var/www/virtual/karate-news.de/neu/htdocs/libraries/joomla/database/database/mysql.php on line 460

Weiß hier jemand Rat?
Danke Melanie
« Letzte Änderung: 03-08-2009 03:53:42 von chraneco » Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #1 am: 04-01-2009 13:18:21 »

Hallo Melanie,
führe bitte in der Datenbank (phpmyAdmin) dieses Query aus:

Code
SELECT * FROM jos_ponygallery AS p
       LEFT JOIN jos_users u
       ON p.owner = u.username
       WHERE u.username IS NULL
 

'jos' entsprechend Deines Präfix vorher austauschen.
Dann sollten die entsprechenden Bilder angezeigt werden.

gruß
Andreas
Gespeichert
Karatenews
Newbie
*
Offline Offline

Beiträge: 16


« Antworten #2 am: 05-01-2009 00:10:10 »

uuuuuhi klasse... jetzt hat die Migration geklappt weil ich diese beiden User rausgelöscht habe. Herzlichen DAnk für deine Hilfe.
Die neue Version ist ja erste Sahne... bei der Migration werden da auch die Bilder verschoben? Ich hatte dies an einem Testserver laufen und quasi die portierte Joomla-Version übertragen mit DB etc... aber ohne Ordnerinhalten, weil das mehrere 1000 Bilder sind (wegen doppelten Speicher etc.)

Weil wenn die Bilder übertragen werden, dann mach ich das ganze nochmal von vorne, richte mir aber die Pony-Galerie gleich korrekt ein, denn jetzt müßte ich durch die Umstrukturierung der Ordner alles per Hand sortieren und hochladen  sm_dead

noch mal danke, hast mir sehr geholfen.
Grüße Melanie

Gespeichert
Karatenews
Newbie
*
Offline Offline

Beiträge: 16


« Antworten #3 am: 06-01-2009 18:39:10 »

So, nachdem ich bei der ersten Migration die Fotos nicht in meinen Ordner am neuen Server hatte, wollte ich das ganze Spiel nochmal von vorne anfangen. Folgende Vorgehensweise:

  • Ich habe die Joomgallery deinstalliert
  • die Tabelleneinträge von der alten Pony nochmals auf dem neuen Server importiert (ohne Fehler geklappt)
  • vom Hoster die Unmengen an Bilder auf dem neuen Server übertragen lassen in den ORdnerpfad von der Pony
  • Jomgallery wieder installiert

Jetzt bekomme ich z.B. beim Aufruf der Ponygalerie folgende Fehler:
Zitat
Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /var/www/virtual/karate-news.de/neu/htdocs/components/com_ponygallery/ponygallery.php on line 994

und auch das Migrationstool der Joomgallery zeigt mir das hier an:
Zitat
Warning: mysql_query() [function.mysql-query]: Access denied for user 'vu2008'@'localhost' (using password: NO) in /var/www/virtual/karate-news.de/neu/htdocs/administrator/components/com_joomgallery/adminclasses/admin.migratep2j.class.php on line 871

jos_joomgallery: row(s)       
jos_joomgallery_catg: row(s)       
jos_joomgallery_comments: row(s)       
jos_joomgallery_votes: row(s)       
jos_joomgallery_nameshields: row(s)       
jos_ponygallery: Access denied for user 'vu2008'@'localhost' (using password: NO)       
jos_ponygallery_catg: Access denied for user 'vu2008'@'localhost' (using password: NO)       
jos_ponygallery_comments: Access denied for user 'vu2008'@'localhost' (using password: NO)       
jos_ponygallery_votes: Access denied for user 'vu2008'@'localhost' (using password: NO)       
jos_ponygallery_nameshields: Access denied for user 'vu2008'@'localhost' (using password: NO) 


So nun stehe ich wieder Verzweifelt hier und weiß nicht weiter  sm_no
Hoffe mir kann jemand helfen...

Viele Grüße
Melanie
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #4 am: 06-01-2009 19:07:51 »

Ich würde Dir gern helfen.
Aber es wäre wahrscheinlich zuviel des Vertrauens, mir einen Zugang zu phpMyAdmin,FTP und der Joomla! Installation auf dem neuen Server zu geben...

Als erstes musst Du Dich um die PonyGallery ML Installation kümmern. Sie muss funktionieren, einschließlich DB-Zugriff und Datei/Ordner-Zugriff.
Bis dahin lass die JoomGallery links liegen, geschweige denn die Migration dorthin.

Nur um sicher zu gehen: Auf dem neuen Server ist Joomla! 1.5.8 und die ported PonyGallery ML 2.5.1 installiert?

Gruß
Andreas


Gespeichert
Karatenews
Newbie
*
Offline Offline

Beiträge: 16


« Antworten #5 am: 06-01-2009 20:12:45 »

HI Andreas,

vielen Dank für das tolle Angebot. Habe dir dazu mal eine PM geschickt mit meinen Zugangsdaten.  sm_smile

Viele Grüße
Melanie
Gespeichert
Karatenews
Newbie
*
Offline Offline

Beiträge: 16


« Antworten #6 am: 07-01-2009 23:22:16 »

Hallo Andreas,

ich glaubs einfach nicht, genau das war der Fehler!!!
Vielen Vielen Dank... Ich bin immer wieder begeistert wie manche Leute bereit sind uneigennützig im Foren zu unterstützen.

Für andere: Die Lösung war in der Configuration, dort war statt MySQL > MySQLi eingetragen!!!

Viele Grüße
Melanie
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #7 am: 07-01-2009 23:48:45 »

Hallo Melanie,
freut mich, dass es funktioniert hat  sm_smile

Das Problem (Fehler würde ich es nicht nennen..) lag an der Joomla! Einstellung in der configuration.php
Zeile 31

Code
var $dbtype = 'mysqli';
 

Das Migrationsscipt verwendet direkte PHP DB Zugriffe, also nicht diejenigen der Joomla! Database, schon aus Gründen einer schnelleren Migration.

Manche Befehle (z.B. 'mysql_query($query);' statt in mysqli: 'mysqli_query($query);') funktionieren aber nicht in einer so während der Joomla! Installation vorgenommenen Einstellung.

Darum bitte ändern in:

Code
var $dbtype = 'mysql';
 

Gruß
Andreas
« Letzte Änderung: 08-01-2009 00:02:21 von aHa » Gespeichert
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 2014 access attempts in the last 7 days.