Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.112 Beiträge in 6.477 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

06-06-2020 19:15:45
JOOM::GALLERY::FORUMArchivJoomGallery 1.5 MVCZusammenspiel mit anderen KomponentenFehlermeldung nach erstellen einer neuen Kategorie
Seiten: [1]
Drucken
Autor Thema: Fehlermeldung nach erstellen einer neuen Kategorie  (Gelesen 3389 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
kajakster
Newbie
*
Offline Offline

Beiträge: 14



« am: 31-03-2010 17:57:30 »

Hallo Zusammen,

Erstelle ich eine neue (Unter) Kategorie und veröffentliche diese, bekomme ich beim Aufruf der gesamten Galerie (oder, falls es sich um eine Unterkategorie handelt bei Aufruf der Überkategorie) die folgende Fehlermeldung:

Fatal error: Call to a member function setQuery() on a non-object in /home/www/xxxxx/xxxx-zzz.de/xxxx/components/com_sh404sef/sef_ext/com_joomgallery.php  on line 41

Diese ist mit einem Link zur 404 Seite versehen. Alles ist wieder normal, wenn ich die Kategorie lösche, oder sie nicht mehr veröffentliche.

Ich vermute, dass es mit sh404sef zusammenhängt. (klar steht ja auch so was in der Meldung)
Bisher habe ich die sef - urls gelöscht, dies hat jedoch nur bewirkt dass fast alle Menüpunkte des Hauptmenüs eine 404 zurückgaben und ich ein Backup wieder einspielen (lassen... sehr guter Hoster..) musste.

Könnt Ihr mir einen Tip geben was ich versuchen könnte um den Fehler zu entfernen?
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #1 am: 01-04-2010 21:25:59 »

Hallo,
tritt der Fehler auf, wenn Du sh404SEF für die JoomGallery deaktivierst?
Welche Version von sh404SEF und der JoomGallery setzt Du ein?

Gruß
Andreas
Gespeichert
kajakster
Newbie
*
Offline Offline

Beiträge: 14



« Antworten #2 am: 02-04-2010 12:37:37 »

Ich nutze die  sh404sef Version 1.0.16_Beta - build_222. mit der aktuellen Version der Joomgallery 1.5.0.4 . Der Fehler trat aber auch mit der 1.5.0.1. auf. Ich muss jetzt aber dazu sagen, dass ich fast ein jahr lang keine Bilder mehr hochgeladen habe, sh404sef war schon länger für die Joomgallery an, und es traten vor einem Jahr keine Fehler auf.

Wenn ich sh404sef für die Joomgallery abschalte dann funktioniert es. Ich bekomme im Frontend keine Fehlermeldung und kann die Kategorie ansehen.

So ich möchte mal sagen, dass ich mich nicht an sh404sef festklammere, auch weil die Komponente kostenpflichtig geworden ist aber ich weiß im Moment keine Kosten - und Backlinkfreie alternative bei der ich die schönen URL´s (und auch die Links darauf) behalten kann.
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #3 am: 02-04-2010 13:20:36 »

Die letzte frei erhältliche Version war -soweit ich weiss- die '15_1.0.20_Beta_build_237'.
Deine müsste also schon eine komerzielle Version sein, oder?
Gespeichert
kajakster
Newbie
*
Offline Offline

Beiträge: 14



« Antworten #4 am: 02-04-2010 14:12:08 »

Nein, weil 1.0.16_Beta - build_222 ist kleiner als die letzte freie Version die '15_1.0.20_Beta_build_237'.

Vielleicht sollte ich aber mal auf die letzte freie Version updaten.

Meint Ihr das könnte was helfen?
Gespeichert
kajakster
Newbie
*
Offline Offline

Beiträge: 14



« Antworten #5 am: 21-06-2010 16:49:46 »

Nach dem Update von sh404 auf die letzte freie Version funktioniert es wieder.
Gespeichert
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 1532 access attempts in the last 7 days.