Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.110 Beiträge in 6.475 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

05-04-2020 19:02:42
JOOM::GALLERY::FORUMArchivJoomGallery 1.5 MVCJoomGallery MVC ALPHA/BETAGelöste Themen: JoomGallery MVCDetailansicht/Lightbox funktioniert nicht mit SEF
Seiten: [1]
Drucken
Autor Thema: Detailansicht/Lightbox funktioniert nicht mit SEF  (Gelesen 4483 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
DerSeppel
Newbie
*
Offline Offline

Beiträge: 3


« am: 01-04-2010 16:29:22 »

Hiho,

habe heute die BETA2 ausprobiert.
Folgendes Problem tritt auf:

Wenn Joomla's SEF aktiviert ist, werden die Detailansichten und die Lightbox-Bilder nicht geladen.
der src= des Links schaut dann so aus:

/bilder/image.raw?type=img&id=42

und das geht dann ins Leere.

Auf mehreren Systemen reproduzierbar. Auch in der BETA1

Gruß

Seppel
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #1 am: 02-04-2010 13:01:19 »

Hi,

poste bitte mal deine SEF-Einstellungen der globalen Konfiguration von Joomla.

Verwendest du eine .htaccess Datei? Falls ja, ist es die Originale von Joomla ohne Änderungen?

Gruß
Chraneco
Gespeichert

Der Sprecher
DerSeppel
Newbie
*
Offline Offline

Beiträge: 3


« Antworten #2 am: 02-04-2010 15:51:53 »

Habe alle drei SEO Optionen auf AN.
Verwende die originale .htaccess
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #3 am: 02-04-2010 16:45:10 »

Hi,

ok, dann sollte es eigentlich funktionieren.

Könntest du uns bitte einen Super-Administrator-Account auf deiner Seite einrichten, damit wir uns das mal direkt ansehen können? Falls du einverstanden bist, sende mir die Daten bitte per PM.

Was genau steht in deiner .htaccess Datei?

Gruß
Chraneco
Gespeichert

Der Sprecher
dVoCex
Newbie
*
Offline Offline

Beiträge: 1


« Antworten #4 am: 02-04-2010 20:30:46 »

Guten Abend,

erstmal vielen Dank für die supertolle Arbeit die Ihr hier leistet, Respekt!  
Konnte auch nicht wiederstehen die Beta zu installieren. Grin

Bei mir tritt das gleiche Problem wie oben beschrieben auf. Auch alle SEF-Optionen aktiviert. Hier meine .htaccess, bis auf eine kleine Änderung weicht diese nicht vom original ab.


Code:
##
# @version $Id: htaccess.txt 13415 2009-11-03 15:53:25Z ian $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

##  Can be commented out if causes errors, see notes above.
#Options +FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On

########## Begin - Additional Settings
#
RewriteCond %{HTTP_HOST} !^www.
RewriteCond %{HTTP_HOST} !^$ [NC]
RewriteRule ^(.*) http://www.%{HTTP_HOST}/$1 [R=301,L]
#
########## End - Additional Settings

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section

Mit freundlichen Grüßen

dVoCex
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #5 am: 02-04-2010 22:55:21 »

Hi,

ok, das Problem ist leider nicht so leicht zu finden.

Wir würden uns das bei euch gerne mal direkt ansehen. Falls ihr damit einverstanden seid, sendet mir bitte die Daten eines Super-Administrator Accounts per PM.

Gruß
Chraneco
Gespeichert

Der Sprecher
DerSeppel
Newbie
*
Offline Offline

Beiträge: 3


« Antworten #6 am: 13-04-2010 18:52:02 »

Mea culpa ...

hab mal neu installiert, jetzt gehts. War wohl irgendeine Altlast ...
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #7 am: 13-04-2010 20:36:16 »

Hi,

das kann sein, bei dVoCex lag es an einem oder zwei System-Plugins, die im Grunde nichts mit der Galerie zu tun haben.

Gruß
Chraneco
Gespeichert

Der Sprecher
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 1633 access attempts in the last 7 days.

mouth