mouth
Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.110 Beiträge in 6.475 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

27-02-2020 09:47:19
JOOM::GALLERY::FORUMArchivPonyGallery MLFrontendGelöste Themen: FrontendDetailansicht Positionierung
Seiten: [1]
Drucken
Autor Thema: Detailansicht Positionierung  (Gelesen 9082 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
duto
Newbie
*
Offline Offline

Beiträge: 8


« am: 26-12-2007 23:23:12 »

Hallo,

wie auch auf der Demoseite der Ponygallery auf dieser Seite - hatte ich auch früher in der Detailansicht eine fixe position der detailbilder.

dh bei jedem weiterklicken auf das nächste oder vorherige bild wurde das detailbild automatisch in meinem browser ganz oben zentriert positioniert.

jedoch habe ich diese einstellung verloren - weiss nicht ob das am upgrade gelegen ist oder am templatewechsel.
viele meiner user beschweren sich nun dass sie bild für bild immer nach unten scrollen müssen da bei jedem klick der browser die seite neu lädt und ganz nach oben springt - so dass das detailbild in meiner ponygallery nicht ganz sichtbar ist.

liegt es an irgendwelchen templateeinstellungen - oder gibt es da in der pony konfiguration etwas womit ich das wieder richten kann?

danke & sorry die etwas verwirrte beschreibung
;)
« Letzte Änderung: 11-04-2008 09:53:07 von mab » Gespeichert
JanTenner
Newbie
*
Offline Offline

Beiträge: 12


« Antworten #1 am: 11-03-2008 15:36:38 »

Bei mir hat es was mit den Namensschildern zu tun. Schalte die Funktion aus und du hast wieder deine Position oben am Rand. Ist Mist, ich weiß, aber mehr fällt mir dazu grad nicht ein.
Find es auch schade dass durch die Namensschild-Funktion der "Klicken Sie auf das Bild, um es in Originalgröße in einem neuen Fenster zu sehen"-Button über das Bild rutscht und da noch so eine Lupe mit eingebaut wurde. ODer kann man das irgendwie kontrollieren? Wollte eh den Bewertungs-Balken dichter an das Bild setzen aber wie das geht weiß ich leider nicht ...
Gespeichert
JanTenner
Newbie
*
Offline Offline

Beiträge: 12


« Antworten #2 am: 11-03-2008 15:41:13 »

oh - grad gesehen dass man das Lupen-Ding ausschalten kann und somit das Positionierungs-Problem auch behoben werden kann, auch mit Namensschild-Funktion:
Detail-Ansicht
Link auf Original-Bilder?
Keine Anzeige


... ach Mist: Dann kann man aber auch nicht mehr das Bild in groß sehen (Lightbox oder so).

Schade.

__________________________
edit:
Komisch: Hab jetzt noch mal alles ausprobiert und jetzt gibts keine Probleme mehr mit der Positionierung!
« Letzte Änderung: 11-03-2008 15:47:34 von JanTenner » Gespeichert
bianka
Newbie
*
Offline Offline

Beiträge: 7


« Antworten #3 am: 06-08-2008 21:01:14 »

hallo,

erstmal vielen dank für diese tolle gallery...

...und nun zu meinem "problem" sm_wink

wie duto schon beschrieben hat, springt bei der detailansicht beim klick auf das vorherige oder nächste bild, sowie auf ein bild der motiongallery, das ganze mainbody nach oben unter die browserleiste. das bild wird sogar halb verdeckt von der navigationsleiste.

wo kann ich diese position festlegen und warum bekommt die "detailansicht nächstes bild" nicht die informationen des ersten klick auf die detailansicht??? da passt sich nämlich alles brav dem template an.

die namensschild funktion habe ich deaktiviert. über einen kleinen tipp für ich mich sehr freuen.

beste grüsse

bianka






wie auch auf der Demoseite der Ponygallery auf dieser Seite - hatte ich auch früher in der Detailansicht eine fixe position der detailbilder.

dh bei jedem weiterklicken auf das nächste oder vorherige bild wurde das detailbild automatisch in meinem browser ganz oben zentriert positioniert.

jedoch habe ich diese einstellung verloren - weiss nicht ob das am upgrade gelegen ist oder am templatewechsel.
viele meiner user beschweren sich nun dass sie bild für bild immer nach unten scrollen müssen da bei jedem klick der browser die seite neu lädt und ganz nach oben springt - so dass das detailbild in meiner ponygallery nicht ganz sichtbar ist.
Gespeichert
mab
Entwickler-Team
Administrator
Hero Member
*****
Offline Offline

Beiträge: 1.279



« Antworten #4 am: 06-08-2008 21:14:03 »

Hi bianka,

könntest Du uns einen Link auf eine entsprechende Seite geben?
Gespeichert

Gruß mab
bianka
Newbie
*
Offline Offline

Beiträge: 7


« Antworten #5 am: 06-08-2008 23:32:24 »

hallo mab,

danke für deine schnelle reaktion. du brauchst eigentlich gar nicht auf meine seite, weil es auch auf eurer pony + joom demoseite passiert.
ich habe es bisher nicht anders gesehen und mich nur gewundert, dass sich keiner dran gestört hat.

ich arbeite mit mac und safari/firefox, aber auch auf einem pc ist der gleiche sprung zu betrachten.

irgendwie bekommt der der nächste bildaufruf immer einen falschen positonbefehl. auch wenn die slideshow aufgerufen wird, positioniert sich das bild ein ganzes stück höher. nach dem ende der slideshow ruscht es dann wieder in die alte position... in den kategorien und galerien ist alles ok. hilft dir das was?

beste grüsse
bianka
Gespeichert
mab
Entwickler-Team
Administrator
Hero Member
*****
Offline Offline

Beiträge: 1.279



« Antworten #6 am: 07-08-2008 10:04:11 »

Hi bianka,

ich muss jetzt nochmal nachfragen: duto hat beschrieben, dass das Bild automatisch ganz oben zentriert angezeigt wurde und das ihm das jetzt fehlt. Bei Dir scheint es andersherum zu sein? Oder?
Wenn ich mir unsere Demos ansehe, dann wird das Detailbild beim Klick auf die Navigation ganz oben zentriert angezeigt. Das liegt daran, dass dort ein Anker hinterlegt ist. Und das ist auch absichtlich so, damit man eben nicht scrollen muss.
Ich verstehe also nicht ganz, was Du meinst, sorry...
Gespeichert

Gruß mab
bianka
Newbie
*
Offline Offline

Beiträge: 7


« Antworten #7 am: 07-08-2008 16:45:11 »

hallo mab,

es wird sicher an den ankern liegen. bin mir aber nicht sicher, ob ich sie richtig entfernen kann. sowohl in der sub_viewdetails.html.php als auch ponygallery.html.php sind verschiedene anker. vielleicht kannst du mir einen tipp geben, welcher part für die vor-und-zurück-ansicht verantwortlich ist. thanks.

ich häng mal noch 2 pics dran, damit du siehst was ich meine:

beste grüße
bianka

edit: habe gerade im web developer gesehen, dass #ponyimg genau unter die browserkante springt, wenn man ein bild weiter geht. gerade dieser anker ignoriert einfach das template, wenn man eine feste navigationsleiste hat.
« Letzte Änderung: 07-08-2008 17:42:53 von bianka » Gespeichert
mab
Entwickler-Team
Administrator
Hero Member
*****
Offline Offline

Beiträge: 1.279



« Antworten #8 am: 07-08-2008 17:53:33 »

Hi bianka,

es betrifft die Datei sub_viewdetails.html.php; um die Anker bei den Vor- und Zurück-Links zu entfernen, ändere die Zeile 107:

vorher:
Code
    $backlink = sefRelToAbs("index.php?option=com_ponygallery&Itemid=$Itemid&func=detail&id=$pid#ponyimg");
 

ersetzen durch:
Code
    $backlink = sefRelToAbs("index.php?option=com_ponygallery&Itemid=$Itemid&func=detail&id=$pid");
 


und die Zeile 132:

vorher:
Code
    $forwardlink = sefRelToAbs("index.php?option=com_ponygallery&Itemid=$Itemid&func=detail&id=$nid#ponyimg");
 

ersetzen durch:
Code
    $forwardlink = sefRelToAbs("index.php?option=com_ponygallery&Itemid=$Itemid&func=detail&id=$nid");
 


Um den Anker auch bei den Minis zu entfernen, ändere die Zeile 454:

vorher:
Code
                    <a href="<?php echo sefRelToAbs("index.php?option=com_ponygallery&amp;Itemid=$Itemid&amp;func=detail&amp;id=$row1->id#ponyimg"); ?>">
 

ersetzen durch:
Code
                    <a href="<?php echo sefRelToAbs("index.php?option=com_ponygallery&amp;Itemid=$Itemid&amp;func=detail&amp;id=$row1->id"); ?>">
 
Gespeichert

Gruß mab
bianka
Newbie
*
Offline Offline

Beiträge: 7


« Antworten #9 am: 07-08-2008 18:18:24 »

hi mab,

erstmal vielen dank für deine unterstützung.

als du dein posting geschrieben hast, habe ich gerade schon alle #ponyimg in der Datei sub_viewdetails.html.php gelöscht. nun funktioniert es wunderbar.

zeile 322 hatte auch noch eins:
             
 <a href="javascript:if (getcoordinates()){ location.href='<?php echo sefRelToAbs("index.php?option=com_ponygallery&amp;Itemid=$Itemid&amp;func=detail&amp;id=$id#ponyimg");?>';}">

ich habe auch dieses entfernt und hoffe doch, dass es nirgendwo vermisst wird.

beste grüße
bianka

edit: um das ganze zu vervollständigen, habe ich auch im Modul Pony Images in der datei modules.class.php in zeile 198 und 324 die #ponyimg entfernt... endlich hört das rumgespringe auf... sm_smile

« Letzte Änderung: 07-08-2008 19:00:53 von bianka » Gespeichert
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 2415 access attempts in the last 7 days.