mouth
Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.110 Beiträge in 6.475 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

27-02-2020 09:43:46
JOOM::GALLERY::FORUMArchivJoomGallery 1.5 MVCInstallationGalerie kaputt nach Update
Seiten: [1]
Drucken
Autor Thema: Galerie kaputt nach Update  (Gelesen 7952 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
vx2000
Newbie
*
Offline Offline

Beiträge: 5


« am: 28-08-2010 09:46:50 »

Hallo,
ich hoffe ihr könnt mir helfen.

Habe gestern zwischen Tür und Angel die aktuelle JoomGallery Version über Auto-Update installiert, anschließend konnte ich keine Bilder mehr sehen.

http://www.elmundo-productions.com/index.php?option=com_joomgallery&Itemid=65

Folgende Fehlermeldung erscheint: Warning: Division by zero in /var/www/web845/html/components/com_joomgallery/views/gallery/tmpl/default.php on line 12

Hat einer ne Ahnung was das sein könnte?

Gruß
VX2000
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #1 am: 28-08-2010 11:45:34 »

Hi,

exportiere mal bitte die Tabelle '#__joomgallery_config' mit Hilfe von PhpMyAdmin und hänge den Export an deinen nächsten Post an.

Gruß
Chraneco
Gespeichert

Der Sprecher
mab
Entwickler-Team
Administrator
Hero Member
*****
Offline Offline

Beiträge: 1.279



« Antworten #2 am: 28-08-2010 11:54:21 »

Hi vx2000,

hast Du ein Backup Deiner Seite? Wahrscheinlich hast Du von einer BETA-Version der 1.0 geupdatet.
Falls Du kein Backup hast, dann wird es wohl notwendig werden, dass Du per phpMyAdmin die Konfigurationstabelle der JoomGallery neu erstellst.
Dazu logst Du Dich bei phpMyAdmin ein und löscht zunächst die Datenbanktabelle xxx_joomgallery_config (xxx steht für Dein Datenbankpräfix; normalerweise jos).
Danach erstellst Du die Datenbanktabelle neu, indem Du den Befehl in der angehängten Datei create_joomgallery_config.txt ausführen lässt. Falls Dein Datenbankpräfix anders als jos lauten sollte, so mußt Du die erste Zeile des Befehls entsprechend anpassen. Nachdem die Tabelle erfolgreich erstellt wurde, führst Du den Befehl aus der angehängten Datei insert_joomgallery_config.txt aus; auch hier muss eventuell das Datenbankpräfix in der ersten Zeile angepasst werden.
Nachdem dieser Befehl ausgeführt worden ist, sollte der Fehler im Frontend nicht mehr auftauchen.
Mit dieser Methode bekommst Du Deine JoomGallery wieder ans laufen; allerdings mußt Du Deine Einstellungen im Konfigurations-Manager im Backend der JoomGallery wieder neu vornehmen, weil jetzt wieder die Standardwerte eingetragen sind.
Überprüfe insbesondere die Bilderpfade.
Gespeichert

Gruß mab
miba15
Newbie
*
Offline Offline

Beiträge: 1


« Antworten #3 am: 12-04-2011 13:04:04 »

vielen dank mab
deine anleitung hat super funktioniert
einfach die bilder werden nicht mehr angezeigt
an was könnte das liegen
habe via ftp geschaut bilder sind vorhanden
und pfad einstellungen bei joomgallery stimmt auch
ev eine idee?
Gespeichert
Claudia E.
Global Moderator
Hero Member
*****
Offline Offline

Beiträge: 1.842



« Antworten #4 am: 12-04-2011 18:08:51 »

Hallo,

was genau meinst du?
Die Bilder werden doch angezeigt?
Gespeichert

Freundliche Grüße von
Claudia
vx2000
Newbie
*
Offline Offline

Beiträge: 5


« Antworten #5 am: 20-06-2011 15:32:11 »

So, ich mal wieder.
Nach jedem Update der Galerie zerschießt es mir diese.

Hier die Fehlermeldung:

Warning: Invalid argument supplied for foreach() in /var/www/web845/html/components/com_joomgallery/helpers/helper.php on line 925

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /var/www/web845/html/libraries/joomla/database/database/mysql.php on line 342
Fotogalerie


Kann damit jemand was anfangen?
Würde mich übner Hilfe sehr freuen.
Gruß
vx2000

Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #6 am: 20-06-2011 19:32:35 »

Hi,

welche Versionen von Joomla, PHP und MySQL sind bei dir installiert?

Gruß
Chraneco
Gespeichert

Der Sprecher
vx2000
Newbie
*
Offline Offline

Beiträge: 5


« Antworten #7 am: 20-06-2011 21:48:05 »

Hallo,
danke dass Du dich mir annimmst.
Habe Joomla 1.5.8, PHP 4 und 5 (kann das sein?) und MySQL 5 installiert.
Gruß
vx2000
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #8 am: 20-06-2011 21:59:15 »

Hi,

es kann sein, dass auf deinem Server sowohl PHP4 als auch PHP5 installiert ist. Verwendet wird zu einem Zeitpunkt aber immer nur eine der Versionen. Welche das ist, kannst du im Backend unter 'Hilfe' -> 'Systeminfo' nachsehen. Die JoomGallery benötigt PHP5.

Auf jeden Fall haben wir den Grund gefunden, warum all deine Updates schieflaufen: Joomla! 1.5.8 ist eine sehr sehr alte Version mit vielen Bugs und Sicherheitslücken. Du solltest dein Joomla unbedingt auf die neueste Version updaten.

Danach sollte ein Update der Galerie kein Problem sein.

Gruß
Chraneco
Gespeichert

Der Sprecher
vx2000
Newbie
*
Offline Offline

Beiträge: 5


« Antworten #9 am: 20-06-2011 22:39:15 »

Ich habe gerade auf Joomla 1.5.23 geupdated, danke für den Tipp.
Also auf dem Server läuft laut Systeminfo die PHP-Version: 5.2.17-0.dotdeb.0
Gruß
vx2000



Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #10 am: 03-11-2011 19:44:51 »

Hi,

ok, das ist für die JoomGallery 1.5.7 ausreichend. Damit sollte die Galerie dann funktionieren.

Gruß
Chraneco
Gespeichert

Der Sprecher
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 2414 access attempts in the last 7 days.