mouth
Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.110 Beiträge in 6.475 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

03-04-2020 22:53:55
JOOM::GALLERY::FORUMArchivPonyGallery MLFrontendGelöste Themen: FrontendCan't view pictures
Seiten: [1]
Drucken
Autor Thema: Can't view pictures  (Gelesen 11117 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
KZrider
Newbie
*
Offline Offline

Beiträge: 6



WWW
« am: 10-03-2008 22:04:33 »

My German isn't very good, so I'm writing this in English.

I've just upgraded from the old PonyGallery (think it was 1.2) to PonyGallery ML 2.5.1. The upgrade seemed to be successful, but I have one major problem. I can't get the resized or or original pictures to show  sm_no. The thumbnails show up like they should, it's just the full size pictures that won't load. It's the same whether I try and view a pre-upgrade picture or a post-update picture. I've tried all the different settings (New window, lightbox, slimbox, etc), but it doesn't seem to have anything to do with that.

I'd really appreciate some help.

Here's a link to the gallery:
http://kzrider.com/index.php?option=com_ponygallery&Itemid=6
« Letzte Änderung: 25-03-2008 12:23:34 von mab » Gespeichert
KZrider
Newbie
*
Offline Offline

Beiträge: 6



WWW
« Antworten #1 am: 10-03-2008 22:39:21 »

Forgot to mention that the problem is only with the frontent. All pictures show up in the backend.

System info:
Apache 2.2.1
MySQL 5.0.22
Php 5.1.6

Joomla 1.0.15
PonyGallery 2.5.1
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #2 am: 11-03-2008 11:54:21 »

Hi,
are you sure you've made an update from the old Ponygallery 1.2?
I thought the development ended with Version 1.1....

Please Check the Configuration manager->General Settings
At the top you can see e.g. the default directories for the images.
Do you see at every path a [Directory is writeable] ?

The same at Watermark File: [The file exist]

Regards
Andreas
Gespeichert
KZrider
Newbie
*
Offline Offline

Beiträge: 6



WWW
« Antworten #3 am: 11-03-2008 13:55:57 »

Excellent! It was the watermark.png file that I hadn't uploaded (didn't think it mattered as I didn't want a watermark on my pictures). Now it works like a charm! PonyGallery ML is hands down THE best gallery component for Joomla, and from what I've read (yeah, I can read a little German), JoomGallery will be even better. Thank you so much for the hard work you've put into this component! I know it's not much, but I've send you a €20 donation to help fund further development.

I do have one more problem. When uploading large picture files (3296px x 2480px, ~1,5 megs), I don't get the usual dialog box with "picture added successfully". It just pulls up a new page that says: Upload complete......Creating thumbnail from JPG, 3296 x 2480..., and then nothing else happens. The picture is uploaded to "originals", and copied to "img_pictures", but not resized, and no thumb created. This only happens with large pictures. My settings appear correct.


Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #4 am: 12-03-2008 16:12:27 »

Hm, i think the pictures are too large for the 'memory_limit' your provider setted. So the script will
stop to work...
Please look at the Joomla! Backend -> Control panel -> System info -> PHP Info -> Memory limit
This picture needs a minimum of 16M or more.

Or try once more with a smaller pic
« Letzte Änderung: 12-03-2008 16:19:17 von aHa » Gespeichert
KZrider
Newbie
*
Offline Offline

Beiträge: 6



WWW
« Antworten #5 am: 12-03-2008 19:12:37 »

I run a dedicated server, and do have the memory_limit set to 16M. I've even tried setting it to 32M, but the problem remains.
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #6 am: 12-03-2008 21:36:55 »

Thank you.
Did you try a smaller picture?
Gespeichert
KZrider
Newbie
*
Offline Offline

Beiträge: 6



WWW
« Antworten #7 am: 12-03-2008 22:08:02 »

As I said in my earlier post, it only happens with large pictures, so it's not that big a deal. But it sure would be nice to be able to upload larger pictures.
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #8 am: 14-03-2008 16:06:25 »

Hm, mab wrote an article about your problems.
Translated in short words you can look at the following settings in your php.ini

upload_max_filesize: the max. size of a file you can upload to your server without errors e.g. 32M
post_max_size: the max. size of a file transfered via a HTML-Form, like the Batchupload in the gallery
memory_limit: we talked about, for a test you can increase this once more to 64M
max_execution_time: max. time in seconds a script is allowed to run until the webserver will interrupt it, increase it to 120s

My server is working very good in uploading bigger pictures with these settings:
upload_max_filesize   200M
post_max_size         200M
memory_limit         128M
max_execution_time   60


I hope it helps.
regards
Andreas
Gespeichert
KZrider
Newbie
*
Offline Offline

Beiträge: 6



WWW
« Antworten #9 am: 14-03-2008 20:18:56 »

That certainly did the trick! Thank you so much.

I made all the changes at the same time, but I'm pretty confident the max_execution_time was to blame. It was set at 30 sec, which would be less than what the server would use to get the large picture uploaded.

Thanks again!
Gespeichert
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 1834 access attempts in the last 7 days.

mouth