Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.112 Beiträge in 6.477 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

09-07-2020 06:28:52
JOOM::GALLERY::FORUMArchivJoomGallery 1.5 MVC - ErweiterungenModuleJoomcat "Link auf Thumbnail" verlinkt falsch
Seiten: [1]
Drucken
Autor Thema: Joomcat "Link auf Thumbnail" verlinkt falsch  (Gelesen 2431 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
MikePro
Newbie
*
Offline Offline

Beiträge: 2


« am: 11-03-2011 11:34:32 »

Hallo,

ich habe Joomcats auf der Startseite www.yownzone.at .
Im Modul habe ich unter "Link auf Thumbnail" eingestellt, dass es in die Kategorie verweisen soll. Dieser Link funktioniert nicht, klickt man allerdings auf den Namenslink unter dem Bild, wird man richtig weitergeleitet. Ich hoffe ihr könnt mir weiterhelfen, ich bin schon am verzweifeln!

Die Fehlermeldung die beim Klicken auf die Thumbnails kommt:

404 - Komponente nicht gefunden!

Die Seite kann nicht angezeigt werden, weil:

   1. Ein veraltetes Lesezeichen
   2. Eine Suchmaschine hat einen veralteten Index der Website
   3. Eine falsche Adresse
   4. Kein Zugriff auf diese Seite!
   5. Die angefragte Quelle wurde nicht gefunden!
   6. Während der Anfrage ist ein Fehler aufgetreten!

Bitte eine der folgenden Seiten ausprobieren:

    * Startseite

Bei Problemen ist der Administrator dieser Website zuständig.



Versionsinfos:
JoomCategories: 1.5.6.1
JoomGallery: 1.5.6.3
JoomImages: 1.5.6.1

lg Mike

EDIT:
Ich habe meinen Provider um Rat gefragt. Er hat folgendes geantwortet:
Den Verlinkungsfehler können wir nicht vollständig nachvollziehen. Bitte wenden Sie sich hierzu an den Anbieter des Moduls.

Wenn man dem Link "http://www.yownzone.at/index.php?view=category&catid=26&Itemid=51&option=" noch "com_joomgallery" anhängt, funktioniert der Link.

http://www.yownzone.at/index.php?view=category&catid=26&Itemid=51&option=com_joomgallery
Warum dies aber fehlt können wir Ihnen nicht sagen.
« Letzte Änderung: 11-03-2011 19:18:03 von MikePro » Gespeichert
Erftralle
Sr. Member
****
Offline Offline

Beiträge: 803


« Antworten #1 am: 11-03-2011 16:54:57 »

Hallo Mike,

da ist noch ein kleiner Fehler im Modul. Danke für den Hinweis.
Bitte ändere in der Datei modules/mod_joomcat/helper.php die Zeile 950

von
Code
          $link = JRoute::_('index.php?&view=category&catid='.$obj->catid.$this->getJoomId());
nach
Code
          $link = JRoute::_('index.php?&view=category&catid='.$obj->catid);

Dann sollte der Link auf dem Thumbnail auch richtig sein.
Der Fehler wird in der nächsten Version des Moduls behoben sein.

Gruß
Erftralle
Gespeichert
MikePro
Newbie
*
Offline Offline

Beiträge: 2


« Antworten #2 am: 11-03-2011 19:17:36 »

Hallo Erftralle,

danke für die Hilfe! Code geändert - funktioniert!

lg Mike
Gespeichert
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 1547 access attempts in the last 7 days.

mouth