mouth
Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.110 Beiträge in 6.475 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

03-04-2020 01:00:03
JOOM::GALLERY::FORUMArchivPonyGallery MLBackend / AdministrationGelöste Themen: Backend / AdministrationSpam-Kommentare
Seiten: [1] 2
Drucken
Autor Thema: Spam-Kommentare  (Gelesen 16647 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
derbermoe
Newbie
*
Offline Offline

Beiträge: 18


WWW
« am: 01-05-2008 11:49:49 »

Hallo zusammen,

seit kurzer Zeit bekomme ich massenweise Bildkommentare mit den üblichen Spaminhalt (Viagra und Co.) und hatte mich deshalb kurzfristig entschieden, die Kommentarfunktion abzustellen, weil ich sie eh nicht benötige.
Leider hat das nicht gewirkt: Obwohl ich im Backend alles ausgestellt habe, trudeln weiterhin Nachrichten ein, dass ein neuer Kommentar erzeugt wurde, der freigeschaltet werden will.

Wie kann das sein und wie funktioniert das? Weiß jemand Rat?
« Letzte Änderung: 06-05-2008 10:56:46 von derbermoe » Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #1 am: 01-05-2008 20:48:16 »

Hi,
könntest Du bitte sagen, welche Einstellungen Du genau im Backend ausgestellt hast?
Setzt Du EasyCaptcha ein?

Danke
Gruß
Andreas
Gespeichert
derbermoe
Newbie
*
Offline Offline

Beiträge: 18


WWW
« Antworten #2 am: 01-05-2008 23:06:14 »

Hi,

die ersten 3 Kommentaroptionen stehen alle auf nein, Genehmigung durch den Admin auch bei registrierten Benutzern, Kommentarspam vermeiden steht auf ja (wobei die Meldung erscheint, dass Easy Captcha nicht installiert ist).

Ich bin eigentlich davon ausgegangen, dass dies nicht von Belang ist, wenn ich die Kommentarfunktion grundsätzlich ablehne.
Oder muss ich noch eine weitere Option anpassen?

Muss ich jetzt EasyCaptcha doch installieren?
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #3 am: 01-05-2008 23:44:47 »

Wie ist bei Dir 'Genehmigung durch den Admin:' und 'Kommentar-Spam vermeiden?' eingestellt.

Ich frage, weil ich Deine Einstellungen im Code nachvollziehen will.
Gespeichert
derbermoe
Newbie
*
Offline Offline

Beiträge: 18


WWW
« Antworten #4 am: 02-05-2008 14:11:27 »

Genehmigung durch den Admin auch bei registrierten Benutzern, Kommentarspam vermeiden steht auf ja (wobei die Meldung erscheint, dass Easy Captcha nicht installiert ist)

Oder meinst du was anderes?
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #5 am: 02-05-2008 18:03:28 »

Ja, danke. Die Informationen habe ich übersehen, sorry  sm_smile
« Letzte Änderung: 02-05-2008 18:06:52 von aHa » Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #6 am: 02-05-2008 18:56:13 »

Es existiert tatsächlich eine Möglichkeit, direkt ohne Aktivierung der Kommentare im Backend diese zu platzieren.
Dies immer mit der Nachricht an den Admin, den neuen Kommentar freizuschalten.
Der Fehler tritt dann auf, wenn die Komponente EasyCaptcha nicht installiert ist. Auch, wenn die Captchas im Frontend nicht
angezeigt werden.

Erste Abhilfe:
Datei sub_commentpic.php, unterhalb des Codes

Code
defined ('_VALID_MOS') or die( 'Direct Access to this location is not allowed.' );
 

diese Zeilen einfügen:

Code
if($ag_showcomment==0 || ($ag_showcomment==1 && $ag_anoncomment==0 && !$my->gid)) {
 die("Stop Hacking attempt!");
}
 

Damit wird bei nicht aktivierter Kommentareingabe allgemein und auch auch bei nicht aktivierter anoymer Kommentareingabe
ein solcher Zugriff unterbunden.

Danke an derbermoe für die Info

Gruß
Andreas

P.S: Natürlich kann auch EasyCaptcha nachinstalliert werden.
Gespeichert
derbermoe
Newbie
*
Offline Offline

Beiträge: 18


WWW
« Antworten #7 am: 04-05-2008 10:08:31 »

Hallo,

ich habe den Code entsprechend eingefüht und werde jetzt noch einmal abwarten und testen, bevor ich EasyCaptcha installiere und hier dann entsprechend berichten. Vielen Dank für die schnelle Hilfe!
Gespeichert
derbermoe
Newbie
*
Offline Offline

Beiträge: 18


WWW
« Antworten #8 am: 06-05-2008 11:01:13 »

Hallo zusammen,

offenbar hat es funktioniert - es sind keine neuen Kommentare mehr eingetroffen.
Leider gibt es aber weiterhin eine stark erhöhte Besucherzahl, die ich auf das nun gelöste Problem zurückführe. Naja vielleicht pendelt sich das auch noch in nächster Zeit ein.

Gibt es vielleicht eine Möglichkeit, die tausenden Benachrichtigungen über neue Kommentare auch außerhalb des Backends zu löschen? Ich würde da sonst mehrere Stunden dransitzen...

Nochmals vielen Dank!
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #9 am: 06-05-2008 16:03:34 »

Hi,
danke für die Rückmeldung.
Tausende Benachrichtigungen haben sich bei Dir angesammelt?

Zur Sicherheit noch einmal nachgefragt: Meinst Du die Benachrichtigungen über neue Kommentare innerhalb des Joomla-Backends oder die Spam-Kommentare selbst?

Die Benachrichtigungen werden in der DB-Tabelle 'jos_messages' gespeichert. Für 'jos_' musst Du das Präfix Deiner Installation verwenden.
Wenn Du sicher bist, dass Du keine Benachrichtigung mehr benötigst, kannst Du diese Tabelle leeren.
Vorher Datenbank sichern! Man kann Leeren und Löschen schnell verwechseln! Zumindest ist es mir schon passiert, dass ich versehentlich die Tabelle gelöscht habe.

Die Kommentare werden in der Tabelle 'jos_ponygallery_comments' gespeichert. Wahrscheinlich befinden sich dort schon Kommentare, die Du behalten willst.
Da ist es nicht mit einem einfachen 'Leeren' getan.

Gruß
Andreas
Gespeichert
derbermoe
Newbie
*
Offline Offline

Beiträge: 18


WWW
« Antworten #10 am: 06-05-2008 20:39:01 »

alles klar danke für die Infos!
Gespeichert
aphex-world
Newbie
*
Offline Offline

Beiträge: 26


« Antworten #11 am: 17-05-2008 17:57:32 »

hi,
ich hab da auch ein ähnliches Problem und zwar habe ich im backend das "Anzeige von Meine Galerie:" abgeschaltet trotzdem bekomm ich immer wieder Nachrichten das User ein neues bild hochgeladen haben.
Auch wenn ich im abgeschalteten modus
Code
index.php?option=com_ponygallery&Itemid=0&func=userpannel
aufrufe komm ich auf die upload seite..

grüße
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #12 am: 18-05-2008 10:59:56 »

Hi aphex-world,
welche Version der Galerie setzt Du ein?
Funktioniert der Aufruf auch, wenn Du nicht eingeloggt bist?
Was verstehst Du unter abgeschaltetem Modus?
Werden auch tatsächlich Bilder hochgeladen oder 'nur' diese Nachrichten verschickt?

Gruß
Andreas
Gespeichert
aphex-world
Newbie
*
Offline Offline

Beiträge: 26


« Antworten #13 am: 18-05-2008 16:49:35 »

hi,
ausgeloggt bekomm ich nicht berechtigt, die bilder werden hochgeladen, von x belibigen usern.
mit abgeschaltetem modus mein ich das ich im backend bei Frontend Einstellungen "Anzeige von Meine Galerie" auf "keine anzeige" gestellt hab.
version: 2.5.1

hab ich vielleicht irgendwas übersehen`? logischerweiße wird ja nur der link im frontet also "Meine Gallery" ausgeblendet und nicht gesperrt?
Gespeichert
vs
Newbie
*
Offline Offline

Beiträge: 27


« Antworten #14 am: 18-05-2008 16:55:35 »

Hallo aphex-world,
eine kleine Idee: einfach mal die Zahl der Bilder, die die User maximal hochladen dürfen auf 0 stellen?

Gruß vs
Gespeichert
Seiten: [1] 2
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 1908 access attempts in the last 7 days.