mouth
Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.112 Beiträge in 6.477 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

10-07-2020 11:13:53
JOOM::GALLERY::FORUMJoomGallery 2.x ACLMigrationMigration Tabellen Prefixe
Seiten: [1]
Drucken
Autor Thema: Migration Tabellen Prefixe  (Gelesen 4378 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
bibabobu
Newbie
*
Offline Offline

Beiträge: 10


WWW
« am: 10-03-2012 02:40:19 »

Guten Abend,

möchte ebenfalls migrieren.
Beim Check erhalte ich folgende Fehlerinfo:       
The old database table prefix cannot be the same than the one for the current Joomla! installation.
Klar steht ja auch in der Migrationsbeschreibung.
Was kann ich tun? Wie ändere ich die alten oder neuen Tabellen Prefixe?
Wobei mir am liebsten wäre ich könnte die neuen mit jos_ belassen.

Folgender Status:

Alt:
Joomla 1.5.22
online
Joom Gallery Version 1.5.6.3
Tabellen Prefix jos_

Neu:
Joomla 2.5.2
Mamp Server lokal
Joom Gallery Version 2.0.0
Tabellen Prefix ebenfalls jos_
Joomla kann nicht neu aufgesetzt werden, da bereits viele Komponenten und Beiträge installiert sind.

Mein Formular:
Database prefix of Joomla! 1.5   :  jos_
Path to Joomla! 1.5              :  -
Path to original images          : http://www.beispiel.de/components/com_joomgallery/img_originals/
Path to detail images            : http://www.beispiel.de/components/com_joomgallery/img_pictures/
Path to thumbnails               : http://www.beispiel.de/components/com_joomgallery/img_thumbnails/
Check owners                     : unchecked

Besten Dank im Voraus für Hilfe.

Gespeichert
bibabobu
Newbie
*
Offline Offline

Beiträge: 10


WWW
« Antworten #1 am: 10-03-2012 10:28:51 »

ok. War wohl schon ziemlich spät.
Habe per FTP die Bilddaten auf den Mampserver geschoben.
Anschließend die Jos_Tabellen der Joomla 1.5 exportiert.
Manuell im SQL File alle Texte "jos_" in "alt_" ersetzt.
Anschließend in die neue Datenbank der Joomla 2.5.2 importiert.
Formular Check mit absoluten Pfgadangaben war alles grün.
Migration ausgeführt.
Anschließend alt_ Tabellen und Migrationsskript wieder gelöscht.

Soweit scheint alles funktioniert zu haben.
Nur habe ich 6 Fehler gemeldet bekommen, welche in der Logdatei stehen sollen.
Wo finde ich diese?

Des Weiteren erhalte ich beim Aufruf des Bildmanagers folgende Fehlermeldung:
JUser: :_load: Fehler beim Laden des Benutzers mit der ID: 62

Wie kann ich diese beseitigen?

Vielen Dank für die Hilfe.
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #2 am: 10-03-2012 11:00:20 »

Hi,

Zitat von: bibabobu
Nur habe ich 6 Fehler gemeldet bekommen, welche in der Logdatei stehen sollen.
Wo finde ich diese?

du findest sie in dem Ordner, der in der globalen Konfiguration vom neuen Joomla! als das Log-Verzeichnis spezifiziert ist.

Zitat von: bibabobu
Des Weiteren erhalte ich beim Aufruf des Bildmanagers folgende Fehlermeldung:
JUser: :_load: Fehler beim Laden des Benutzers mit der ID: 62

Wie kann ich diese beseitigen?

Gehe bitte in den Wartungsmanager der Galerie, führe einen Check aus und behebe mit den angebotenen Buttons dort dann die gefundenen Problemstellen.

Gruß
Chraneco
Gespeichert

Der Sprecher
bibabobu
Newbie
*
Offline Offline

Beiträge: 10


WWW
« Antworten #3 am: 10-03-2012 11:46:26 »

Habe Dir mal die Log gemailt.

Mit dem Wartungsmanager bekomme ich den Fehler "JUser" nicht behoben.
Ist in dem Logfile etwas zu erkennen.
Ich glaube am Ende steht das irgendwelche alten Einstellungen nicht übernommen wurden.
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #4 am: 10-03-2012 14:28:13 »

Hi,

du hast nicht von der aktuellen JoomGallery 1.5.7 migriert. Dies ist notwendig, um die Migration erfolgreich abschließen zu können.
Spiele deshalb bitte ein Backup ein und führe vor dem nächsten Migrationsversuch ein Update auf die JoomGallery 1.5.7 aus.

Führe bitte dann vor der Migration bitte auch noch einen Check im Wartungsmanager der alten Galerie aus, um sicher zu gehen, dass alle alten Bilder vorhanden sind. Laut der Log-Datei wurden ein paar wenige alte Bilder nicht gefunden.

Zitat von: bibabobu
Mit dem Wartungsmanager bekomme ich den Fehler "JUser" nicht behoben.

Was genau ist passiert?

Gruß
Chraneco
Gespeichert

Der Sprecher
bibabobu
Newbie
*
Offline Offline

Beiträge: 10


WWW
« Antworten #5 am: 10-03-2012 23:03:01 »

So spät am Abend.
Habe das ganze Prozedere noch mal durchgemacht.
Alles gleich wie beim ersten mal, trotz altem Gallery Update auf 1.5.7.

Aber ich habe experimentiert und habe den "Juser" Fehler behoben bekommen.
Ich habe in der SQL Tabelle die Owner ID von alt 62 auf neu 42 aller Bilder mit einem SQL Replace Befehl ersetzt.
Und siehe da keine Fehlermeldung mehr.
Es scheint nun fürs Erste alles zu funktionieren...so hoffe ich.
Warum auch immer. Kenne mich damit eigentlich nicht aus.

Trotzdem erst einmal vielen Dank für die Geduld und Hilfe.
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #6 am: 11-03-2012 15:59:13 »

Hi,

nach Update auf die 1.5.7 hätte der Fehler mit den Einstellungen bei der Migration eigentlich nicht mehr auftauchen düfen.

Wenn du bei der Migration 'Check owners' aktivierst, würden die Benutzer bei der Migration automatisch überprüft und ersetzt werden.

Könntest du mir bitte noch einmal die Log-Datei schicken (einfach die PHP-Datei ohne den Inhalt wo anders hinzukopieren)?

Hast du vor der Migration in der alten Galerie einen Check im Wartungsmanager durchgeführt?

Gruß
Chraneco
Gespeichert

Der Sprecher
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 1339 access attempts in the last 7 days.

mouth