mouth
Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.110 Beiträge in 6.475 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

06-04-2020 15:18:23
JOOM::GALLERY::FORUMArchivJoomGallery 1.5 MVC - ErweiterungenMambots / PluginsJoomPlu: Verlinkung mit Detailansicht funktioniert nicht
Seiten: [1]
Drucken
Autor Thema: JoomPlu: Verlinkung mit Detailansicht funktioniert nicht  (Gelesen 4673 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
kent.brockman
Newbie
*
Offline Offline

Beiträge: 9


« am: 30-05-2012 09:18:46 »

Hi,

wenn ich mittels JoomPlu ein Thumbnail-Bild in meinen Bericht einbinde und diesen mit der Detailansicht verlinke, funktioniert der Link anschliessend nicht und ich komme beim Klick auf das Thumbnail nur auf eine Error-404-Seite.

Beispiel:
http://www.bslg.net/index.php?option=com_content&view=article&id=686:deutsche-meisterschaften-2012-in-berlin-silbermedaille-fuer-annalena-jacob-ueber-50m-freistil&catid=1:bslg&Itemid=2

Der Link im Artikel lautet: "http://www.bslg.net/joomplu:552%20type=img"... das kann ja nicht funktionieren.

Hat jemand eine Idee, was da schief läuft?

Danke,


KentBrockman
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #1 am: 30-05-2012 13:25:07 »

Hi,

welchen Editor verwendest du?

Funktioniert es, wenn du das Thumbnail bei abgeschaltetem Editor einfügst?

Gruß
Chraneco
Gespeichert

Der Sprecher
kent.brockman
Newbie
*
Offline Offline

Beiträge: 9


« Antworten #2 am: 12-06-2012 18:28:43 »

Hallo,


ich verwende den TinyMCE

Wenn ich gar keinen Editor verwende, wird das Thumbnailbild nicht angezeigt, aber der Link auf die Detailansicht funktioniert...

mysteriös...
Gespeichert
kent.brockman
Newbie
*
Offline Offline

Beiträge: 9


« Antworten #3 am: 12-06-2012 18:45:44 »

Nochmal ich...

ich habe es mir nochmal etwas genauer angesehen: Bei einem anderen Projekt, das ich nebenbei noch betreibe, läuft alles, wie es soll.

Wenn ich im Editor ein Bild einbinde und mit der Detailansicht verlinke sieht das im HTML-Code so aus:
<p><a href="joomplu:197 type=img"><img class="jg_photo" src="index.php?option=com_joomgallery&amp;view=image&amp;format=raw&amp;id=197&amp;type=thumb" border="0" alt="joomplu:197" style="float:left;" /></a>

In meinem Projekt, in dem es *nicht* funkioniert, sehe ich folgendes im HTML-Code:
<p><a href="http://www.bslg.net/joomplu:28 type=img"><img class="jg_photo" src="http://www.bslg.net/index.php?option=com_joomgallery&amp;view=image&amp;format=raw&amp;id=28&amp;type=thumb" alt="joomplu:28" /></a>

Was fällt auf? In dem fehlerhaften Projekt sind absolute Pfade angegeben (http://www.bslg.net/...) und in dem anderen nur die relativen, also ohne Domain... Ist das ein Ansatz zur Problemlösung? Wenn ja, wo kann ich einstellen, ob absolute oder relative Pfade verwendet werden sollen?
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #4 am: 12-06-2012 19:41:25 »

Hi,

jep, das ist die Stelle, die das Problem verursacht.

Da es, wie du sagst, aber richtig funktioniert, wenn der Editor deaktiviert ist, ist es dieser Editor, der die Veränderung unerlaubter Weise durchführt.
Du müsstest diesbezüglich also mal beim Entwickler dieses Editors nachfragen, warum das passiert. Eventuell gibt es bei den Einstellungen des Editors sogar eine Option dafür.
Es wäre nett, wenn du das Ergebnis dann auch hier posten könntest.

Gruß
Chraneco
Gespeichert

Der Sprecher
kent.brockman
Newbie
*
Offline Offline

Beiträge: 9


« Antworten #5 am: 14-06-2012 22:34:23 »

Hi,

das Problem ist teilweise gelöst: Ich kann im TinyMCE die Pfad-Einstellung von "absolut" auf "relativ" umstellen... und dann funktioniert das verlinken. ABER NUN WIRD DAS THUMBNAIL-BILD NICHT MEHR ANGEZEIGT... *verzweifel*

Im Editor-Fenster wird das Bild korrekt angezeigt und wenn ich auf "Speichern"-Klicke erscheint nur der Platzhalter für "Bild nicht gefunden" :-(

Im Quelltext finde ich als URL auf das Bild folgende:
http://www.bslg.net/index.phpoption=com_joomgallery&view=image&format=raw&id=28&type=thumb

Es fehlt das Fragezeiche zwichen "index.php" und "option", also so wäre es korrekt:
http://www.bslg.net/index.php?option=com_joomgallery&view=image&format=raw&id=28&type=thumb

Wenn ich auf Artikel bearbeiten klicke, wird das Bild wieder angezeigt und im HTML-Quellcode ist das Fragezeichen vorhanden. Auch in der Datenbank sehe ich den korrekten Link.

Hat jemand eine Idee, was nun schief läuft?


Danke,

Kent
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #6 am: 20-06-2012 15:33:53 »

Hi,

auch diese Änderung wird vermutlich durch den Editor durchgeführt.

Die JoomGallery fügt auf jeden Fall einen korrekten Link in das Textfeld ein (wie man überprüfen kann, wenn man den Editor deaktiviert).
Für alles was danach geschieht muss der Editor verantwortlich sein. Die JoomGallery hat darauf leider keinen Einfluss mehr.

Versuche es mal bitte mit einem anderen Editor.

Gruß
Chraneco
Gespeichert

Der Sprecher
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 1658 access attempts in the last 7 days.