mouth
Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.112 Beiträge in 6.477 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

28-05-2020 22:40:30
JOOM::GALLERY::FORUMJoomGallery 2.x ACLSonstigesThumbnails werden auf Facebook nicht mehr angezeigt
Seiten: [1]
Drucken
Autor Thema: Thumbnails werden auf Facebook nicht mehr angezeigt  (Gelesen 5485 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
brunnerphilippat
Newbie
*
Offline Offline

Beiträge: 22


« am: 04-03-2013 20:02:13 »

Seite einigen Tagen zeigt meine Facebookseite beim Posten von Galeriekategorien keine Thumbnail auswahl mehr an. Vl. ist das Problem ja schon bekannt und mir könnte jemand verraten wie man
de Problem mächtig werden könnte.

Lg und Danke Philipp
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #1 am: 04-03-2013 21:56:02 »

Hi,

die JoomGallery steht bis jetzt eigentlich nur über den Like-Button in der Detailansicht oder die Comments in Verbindung mit Facebook.

Ein Posten von Thumbnails wird nicht unterstützt.
Wie hast du das bisher gemacht?

Gruß
Chraneco
Gespeichert

Der Sprecher
brunnerphilippat
Newbie
*
Offline Offline

Beiträge: 22


« Antworten #2 am: 04-03-2013 22:54:35 »

Ich hab mich wohl schlecht ausgedrückt. Habs immer so gemacht:
Kategorie erstellt --> Bilder hochgeladen --> Frontend die Kategorie geöffnet --> Browser Link kopiert und in Facebook eingefügt.

Vorher kamen immer so an 10 Fotothumbnails zur Auswahl und jetz kommt leider kein einziges mehr und man kann nur mehr den Link
ohne Thumbnail posten. An der Komponente oder den Modulen wurde nichts geändert bevors nicht mehr funktionierte.

Lg Philipp
Gespeichert
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #3 am: 05-03-2013 00:38:17 »

Hi,

wenn du an der Komponente und anderen Erweiterungen nichts geändert hast, muss sich seitens Facebook etwas geändert haben.
Gibt es darüber eventuell Informationen?
Auf jeden Fall steht das dann nicht mehr in unserem Einflussbereich.

Gruß
Chraneco
Gespeichert

Der Sprecher
jdgf
Jr. Member
**
Offline Offline

Beiträge: 165


WWW
« Antworten #4 am: 15-03-2013 10:44:05 »

Hallo,

das Problem hatte und habe ich auch. Zur Zeit findet Facebook gar keine Fotos mehr auf meiner Seite. Ich bilde mir ein, dass Facebook nach dem img-Tag sucht. Zumindest wurde ein über den JCE-Editor eingefügtes Einzelbild von Facebook gefunden. Ebenso hat Facebook früher die über joom categories und joomimgages angezeigten Fotos gefunden und übernommen. Seit mehreren Wochen wurde wahrscheinlich die Programmierung in Facebook wieder geändert und seitdem werden keine Thumbnails mehr übernommen.

Ich habe zu dem Problem schon unter http://www.forum.joomgallery.net/index.php/topic,5039.0.html und hier http://www.forum.joomgallery.net/index.php/topic,4672.0.html gepostet.

Gruß Dietmar
Gespeichert

Täglich aktuell aus dem Hohenfelser Land
https://www.kolping-hohenfels.de
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #5 am: 15-03-2013 13:47:52 »

Hi,

es könnte wirklich an den nicht echten Dateipfaden liegen, allerdings frage ich mich, warum Facebook das jetzt plötzlich ausschließt.

Ein Ändern auf echte Dateipfade im Plugin ist nur sehr schwer möglich, allerdings könnten die Dateipfade nachträglich mit SEF in echt aussehende Dateipfade umgewandelt werden. Das funktioniert dann aber nur, wenn man das Joomla!-eigene SEF verwendet.

Ich werde das in den nächsten Tagen mal ausprobieren und hoffentlich eine Lösung posten können.

Gruß
Chraneco
Gespeichert

Der Sprecher
jdgf
Jr. Member
**
Offline Offline

Beiträge: 165


WWW
« Antworten #6 am: 28-03-2013 13:10:57 »

Aktuell geht es seit Montag wieder. An meinen Einstellungen wurde nichts geändert. --> https://de-de.facebook.com/Hohenfelser.Land
Gespeichert

Täglich aktuell aus dem Hohenfelser Land
https://www.kolping-hohenfels.de
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #7 am: 30-03-2013 12:51:27 »

Hi,

ok, trotzdem könntet ihr mal Folgendes zusammen mit dem Joomla!-eigenen SEF probieren:

Zunächst muss die '.htaccess' erweitert werden, indem die Zeile

Code:
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]

durch diese ersetzt wird:

Code:
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw|jpg))$ [NC]

Dadurch werden auch Seiten mit der Endung .jpg durch die SEF-Funktionen geschickt.

Um die neuen URLs zu aktivieren, muss dann in Zeile 160 der Datei 'components/com_joomgallery/router.php' die Variable $sef_image von 0 auf entweder 1 oder 2 gesetzt werden. Verwendet man 1 wird eine einfache SEF-URL erzeugt, die aber den Alias des jeweiligen Bildes nicht enthält. Möchte man das auch der Alias in der URL erscheint, muss man 2 verwenden, was bei sehr vielen Bildern auf einer Seite aber eventuell den Seitenaufbau etwas verlangsamt, da für jedes Bild eine SQL-Query gestartet wird.

Zuletzt muss die PHP-Datei des Content-Plugins im Ordner 'plugins/content/joomplu' mit der im Anhang ersetzt werden.

Damit erhalten dann alle Bilder der Galerie wieder eine Endung .jpg und sollten überall korrekt erkannt werden.

Gruß
Chraneco
Gespeichert

Der Sprecher
jdgf
Jr. Member
**
Offline Offline

Beiträge: 165


WWW
« Antworten #8 am: 15-04-2013 09:29:06 »

Danke für die tolle Unterstützung. Ich habe alles am Samstag eingebaut und am Sonntag ausprobiert. Das Foto des Artikels wurde in Facebook angezeigt (https://de-de.facebook.com/Hohenfelser.Land).
Gespeichert

Täglich aktuell aus dem Hohenfelser Land
https://www.kolping-hohenfels.de
Chraneco
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 4.066



« Antworten #9 am: 15-04-2013 13:42:56 »

Hi,

alles klar, vielen Dank für den Test und die Rückmeldung!

Gruß
Chraneco
Gespeichert

Der Sprecher
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 2001 access attempts in the last 7 days.

mouth