mouth
Willkommen Gast.
Um die volle Funktionalität des Forums nutzen zu können,
müssen Sie sich einloggen oder registrieren.
Haben Sie Ihre Aktivierungs E-Mail übersehen?

 
Erweiterte Suche

31.110 Beiträge in 6.475 Themen- von 6.477 Mitglieder - Neuestes Mitglied: Frideborg

06-04-2020 19:49:01
JOOM::GALLERY::FORUMArchivPonyGallery MLBackend / AdministrationGelöste Themen: Backend / AdministrationEinstellungen werden nicht übernommen
Seiten: [1]
Drucken
Autor Thema: Einstellungen werden nicht übernommen  (Gelesen 10494 mal)
0 Mitglieder und 1 Gast betrachten dieses Thema.
ponyTom
Newbie
*
Offline Offline

Beiträge: 8


« am: 16-07-2008 19:09:32 »

Hi,

ich habe zu dem Thema einen anderen Beitrag gefunden, der so ungefähr passt - aber da wars ein User - error...
Ggf ists hier auch einer - aber sicher ein anderer  sm_bigrazz

Mein Problem liegt darin, dass eine Einstellung, die ich im Backend vornehme, nicht gespeichert wird.

Ich habe die PonyGallery 2.5.1 Build 2008226 unter Joomla 1.0.15 (register Globals = off, safeMode) am laufen und sie zeigt auch alle Bilder, erlaubt uploads usw - bloss die Einstellungen "frisst" sie nicht.

Ich habs bemerkt, als ich als Detailbildansicht die Lightbox aktivieren wollte - das wird nicht übernommen und beim nächsten Aufruf stehts wieder auf "Normale Ansicht".

Um sicher zu gehen, dass es nicht der gleiche User error wie im genannten Beitrag ist, hab ich die Administration mal mit und ohne "www" aufgerufen - beide Male das gleiche.
Ob bestimmte Schreibrechte notwendig sind, weiss ich nicht und finde nix dazu, jedenfalls werden die Einstellungen doch sicher in der DB und nicht in einer (dann notwendigerweise beschreibbaren) Datei gesichert?

Wäre super, wenn ihr einen Tip für mich hättet, wo ich noch suchen soll - ich weiss nicht mehr weiter  Sad

LG
PonyTom
« Letzte Änderung: 17-07-2008 17:16:48 von ponyTom » Gespeichert
Claudia E.
Global Moderator
Hero Member
*****
Offline Offline

Beiträge: 1.842



« Antworten #1 am: 16-07-2008 20:40:26 »

Hallo PonyTom, sm_smile

gibt es keine Fehlermeldung?
War das eine frische Pony-Installation oder hast du ein Update durchgeführt?
Gespeichert

Freundliche Grüße von
Claudia
ponyTom
Newbie
*
Offline Offline

Beiträge: 8


« Antworten #2 am: 16-07-2008 21:26:36 »

Hi,

leider keine Fehlermeldung zu sehen und die Inst war neu auf ein "frisches" Joomla...

LG
PonyTom
Gespeichert
Claudia E.
Global Moderator
Hero Member
*****
Offline Offline

Beiträge: 1.842



« Antworten #3 am: 16-07-2008 21:51:59 »

Bekommst du nach dem Klick auf Save die Meldung Einstellungen gespeichert?
Gespeichert

Freundliche Grüße von
Claudia
ponyTom
Newbie
*
Offline Offline

Beiträge: 8


« Antworten #4 am: 16-07-2008 21:58:22 »

Hi,

ne, es springt in die Cpanel- Übersicht..

Wäre das so nicht OK?
Von "Einstellungen gespeichert" is nix zu sehen, von einer Fehlermeldung aber auch nicht...  sm_dead

LG
PonyTom
Gespeichert
aHa
Entwickler-Team
Hero Member
*****
Offline Offline

Beiträge: 2.367


WWW
« Antworten #5 am: 17-07-2008 00:02:22 »

Hallo PonyTom,

rufe bitte im Backend von Joomla im Menü 'System' den Menüpunkt 'System Info' auf. Dort klicke bitte auf den Tab 'PHP Info'

Findest Du dort einen Eintrag wie zum Beispiel:
 
Code:
'This server is protected with the Suhosin Patch 0.9.6
Copyright (c) 2006 Hardened-PHP Project'

oder ähnlich?

Gruß
Andreas

Gespeichert
ponyTom
Newbie
*
Offline Offline

Beiträge: 8


« Antworten #6 am: 17-07-2008 07:52:05 »

Hi aHa,

ne, so ein Eintrag (oder ähnlich) gibts da nicht...

Ist übrigens ein shared Hosting von Speedbone, auf dem ich bereits verschiedene andere Joomlas am Laufen habe...

LG
PonyTom
Gespeichert
ponyTom
Newbie
*
Offline Offline

Beiträge: 8


« Antworten #7 am: 17-07-2008 07:57:41 »

HA!
 Shocked

hab grade mal auf die URL geachtet nach dem Speichen:

http://www.Domainname.de/administrator/index2.php?option=com_ponygallery&act=config&mosmsg=Die+Konfigurations-Datei+ist+nicht+beschreibbar%21

Aha, eine Konfigurationsdatei - also doch!
Das wird auf der Seite nicht als Fehler gezeigt, wo finde ich denn die Konfigurationsdatei und wie heisst sie?

LG
PonyTom
Gespeichert
mab
Entwickler-Team
Administrator
Hero Member
*****
Offline Offline

Beiträge: 1.279



« Antworten #8 am: 17-07-2008 10:24:33 »

Hi ponyTom,

normalerweise sollte diese Meldung angezeigt werden...
Das Konfigurations-File findest Du in administrator/components/com_ponygallery und es heißt config.ponygallery.php

Gespeichert

Gruß mab
ponyTom
Newbie
*
Offline Offline

Beiträge: 8


« Antworten #9 am: 17-07-2008 17:14:46 »

Hi,

JAU! Das wars  Grin

Musste nur der genannten Datei chmod 777 verpassen, nun klappts.

LG & Danke für die Hilfe

PonyTom
Gespeichert
Claudia E.
Global Moderator
Hero Member
*****
Offline Offline

Beiträge: 1.842



« Antworten #10 am: 17-07-2008 20:32:31 »

Tu dir bitte selbst den Gefallen und lasse die Datei nicht auf 777 (also allgemeiner Zugriff) stehen. Theoretisch sollte 644 reichen.
Wenn das bei dir nicht der Fall ist, ändere die Rechte lieber vor jedem Ändern (macht man ja nicht täglich sm_smile).
Ist sicherer, als sie auf 777 zu lassen.

Das ist nur ein kleiner Hinweis. sm_smile
Gespeichert

Freundliche Grüße von
Claudia
ponyTom
Newbie
*
Offline Offline

Beiträge: 8


« Antworten #11 am: 17-07-2008 21:23:57 »

Hi,

hätte ich auch nicht - bloss: da lag eben der Fehler...

Das Prob ist immer, dass Joomla einen anderen user (näml. den php-user) als den FTP-User nutzt.
644 reichte leider nicht und ein ded. server ists nicht, ich muss mal sehen, wie ichs einstelle...

LG & nochmals Danke
PonyTom
Gespeichert
mab
Entwickler-Team
Administrator
Hero Member
*****
Offline Offline

Beiträge: 1.279



« Antworten #12 am: 17-07-2008 21:30:38 »

Hi ponyTom,

stelle die Datei mal auf 766; das ist sicherer und müßte auch genügen.
Gespeichert

Gruß mab
teachy
Newbie
*
Offline Offline

Beiträge: 1


« Antworten #13 am: 26-07-2008 15:48:27 »

Sorry for the english. reading German is a bit ok, but writing not, but i really need some help. I have the same problem and followed the same procedure. But i dont understand this :

-------------
JAU! Das wars  Grin

Musste nur der genannten Datei chmod 777 verpassen, nun klappts.

LG & Danke für die Hilfe

--------------------------

i dont understand this. Can you tell me what you did ?
Gespeichert
ponyTom
Newbie
*
Offline Offline

Beiträge: 8


« Antworten #14 am: 26-07-2008 18:42:39 »

Hi teachy,

this only means "wow - OK, here was the problem"

In most FTP-Client you can change the file attributes; just switch them to 777 for the file "config.ponygallery.php" in administrator/components/com_ponygallery.
Then it will work.

After you've finished your changes switch the file back because of security reasons.

Best Regards
ponyTom
Gespeichert
Seiten: [1]
Drucken
Gehe zu:  

HOSTED BY SCHWARZKÜNSTLER ®

PROTECTED BY  ZB BLOCK  AND Project Honey Pot
Theme orange-lt created by panic

Bad Behavior has blocked 1661 access attempts in the last 7 days.